zoj3609 Modular Inverse(扩展欧几里德算法求逆元)模板

 

Time Limit: 2 Seconds Memory Limit: 65536 KB


The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input

3
3 11
4 12
5 13

Sample Output

4
Not Exist
8
 
题意:已知a,m求最小的x满足ax≡1(mod m)

代码:扩展欧几里得求逆元代码


#include <cstdio>

#include <iostream>

using namespace std;

int ext_gcd(int a,int b,int &x,int &y){//扩展欧几里得求,一组解x,y

    if(!b) {x=1,y=0;return a;}

    int d=ext_gcd(b,a%b,y,x);

    y-=a/b*x;

    return d;

}

int Inv(int a,int m){

    int d,x,y;

    d=ext_gcd(a,m,x,y);

    if(1!=d) return -1;//gcd(a,b)!=1此时无解,证明a,m不互质,

    else return (x%m+m)%m;//x可能为负,相当于取绝对值

}

int main()

{

    int T,a,m;

    cin>>T;

    while(T--)

    {

        cin>>a>>m;

        if(m==1){

            puts("1");

            continue;

        }

        int d=Inv(a,m);

        if(-1==d) puts("Not Exist");

        else cout<<d<<endl;

    }

    return 0;

}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值