poj 3616 Milking Time【最大递增子序列】

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input
* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output
* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43
题意:
奶牛为自己规划下面n时间内的产奶,m个时间段(时间小于n),每个段有a,b,c表示从a时到b时共可产奶c。挤奶工每次挤奶必须挤完完整的时间段,且每次挤完奶牛需要休息r时,求最终可获得的牛奶最大值
思路:
先贪心预处理,sort按照最早结束产奶的排序,由于会出现区间覆盖问题,前值会影响后值,所以用dp思想更新值,类似于最大递增子序列(不是最长)。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define max_n 1010
using namespace std;
typedef long long LL;
LL dp[max_n];
//dp[i]: 表示第i位奶牛产奶的最大量
struct node {
    LL a;
    LL b;
    LL c;
}s[max_n];

bool cmp(node x, node y) {
    return x.b < y.b;
}

int main() {
    LL n, m, R, maxn = 0;
    memset(dp, 0, sizeof(dp));
    scanf("%lld %lld %lld", &n, &m, &R);
    for(LL  i = 0; i < m; i++) {
        scanf("%lld %lld %lld", &s[i].a, &s[i].b, &s[i].c);
    }
    sort(s, s + m, cmp);
    for(LL i = 0; i < m; i++) {
        dp[i] = s[i].c;
        for(LL j = 0; j < i; j++) {
            if(s[i].a - s[j].b >= R) {
                dp[i] = max(dp[i], dp[j] + s[i].c);
            }
        }
        maxn = max(dp[i], maxn);
    }
    printf("%lld\n", maxn);
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值