杭电acm 4142Triangle(小学生题,判断三角形)

Triangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 442    Accepted Submission(s): 262


Problem Description
A triangle is one of the basic shapes of geometry: a polygon with three corners or vertices and three sides or edges which are line segments.
Triangles can be classified according to the relative lengths of their sides:
· In an equilateral triangle all sides have the same length. An equilateral triangle is also a regular polygon with all angles measuring 60°.
· In an isosceles triangle, two sides are equal in length. An isosceles triangle also has two angles of the same measure; namely, the angles opposite to the two sides of the same length; this fact is the content of the Isosceles triangle theorem.
· In a scalene triangle, all sides are unequal. The three angles are also all different in measure. Some (but not all) scalene triangles are also right triangles.
 

Input
The first line of input contains an integer (1 <= T <= 100), the number of test cases. T test data sets follow, each data set consists of 3 integers A, B and C, where (1 <= A,B,C <= 1,000,000) the triangle side lengths.
 

Output
For each test case, print “equilateral”, “isosceles” or “scalene” describing the triangle type. If the input doesn’t create a valid triangle output “invalid!”. Follow the output format below.
 

Sample Input
  
  
2 3 3 4 6 4 2
 

Sample Output
  
  
Case #1: isosceles Case #2: invalid!
 

Source
想法:
水题
代码:
#include<stdio.h>
#include<string.h>
int main()
{
    int T;
    scanf("%d",&T);
    int ws=1;
    while(T--)
    {
      int a,b,c;
      scanf("%d %d %d",&a,&b,&c);
      printf("Case #%d: ",ws++);
     if(a+b>c&&a+c>b&&b+c>a)
      {
          if(a==b&&b==c&&c==a)
            {
            printf("equilateral\n");
            }
            else if(a==b||b==c||c==a)
            {
            printf("isosceles\n");
            }
            else printf("scalene\n");
      }
      else
      {
         printf("invalid!\n");
      }
    }
    return 0;
}
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值