【Jason's_ACM_解题报告】The Triangle(POJ1163)

The Triangle(POJ1163)

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30


经典问题,状态第[i][j]个数字,状态转移方程d[i][j]=a[i][j]+max(d[i+1][j],d[i+1][j+1]);

使用三种方式解决:

第一种,递归,但是由于数据n的取值范围为[1,100],O(2^n)的递归方式无法承受。

第二种,递推,指令式指定运算顺序。

第三种,记忆化搜索,声明式编程风格,每次递归记录已计算的子问题结果,减少重叠子问题的重复计算。


附代码如下:

第一种:

#include<cstdio> 
#include<algorithm> 

using namespace std;

#define MAXN (100+5)

int a[MAXN][MAXN];
int n; 

int solve(int i,int j){
	return i==n-1?a[i][j]:max(solve(i+1,j),solve(i+1,j+1))+a[i][j];
}

int main(){
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		for(int j=0;j<=i;j++){
			scanf("%d",&a[i][j]);
		}
	}
	printf("%d\n",solve(0,0));
	
	return 0;
}

第二种:

#include<cstdio> 
#include<cstring>
#include<algorithm> 

using namespace std;

#define MAXN (100+5)
#define CLR(x,y) (memset(y,x,sizeof(y)))

int a[MAXN][MAXN],d[MAXN][MAXN];
int n; 

int main(){
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		for(int j=0;j<=i;j++){
			scanf("%d",&a[i][j]);
		}
	}
	CLR(-1,d);
	for(int j=0;j<=n-1;j++)d[n-1][j]=a[n-1][j];
	for(int i=n-2;i>=0;i--){
		for(int j=0;j<=i;j++){
			d[i][j]=a[i][j]+max(d[i+1][j],d[i+1][j+1]);
		}
	}
	
	printf("%d\n",d[0][0]);
	
	return 0;
}

第三种:

#include<cstdio> 
#include<cstring>
#include<algorithm> 

using namespace std;

#define MAXN (100+5)
#define CLR(x,y) (memset(y,x,sizeof(y)))

int a[MAXN][MAXN],d[MAXN][MAXN];
int n; 

int solve(int i,int j){
	if(d[i][j]>-1)return d[i][j];
	return d[i][j]=i==n-1?a[i][j]:a[i][j]+max(solve(i+1,j),solve(i+1,j+1));
}

int main(){
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		for(int j=0;j<=i;j++){
			scanf("%d",&a[i][j]);
		}
	}
	CLR(-1,d);
	printf("%d\n",solve(0,0));
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值