2017年河南省ACM省赛 Problem F: Binary to Prime

问题 F: Binary to Prime

时间限制: 1 Sec  内存限制: 128 MB

题目描述

To facilitate the analysis of  a DNA sequence,  a DNA sequence is represented by a binary  number. The group of  DNA-1 has discovered a great new way .  There is a certain correlation between binary number and prime number. Instead of using the ordinary decadic numbers, they use prime base numbers. Numbers in this base are expressed as sequences of zeros and ones similarly to the binary numbers, but the weights of bits  in the representation are not powers of two, but the elements of the primes  ( 2, 3, 5, 7,... ).

 

For example  01101 , ie. 2+5+7=14

 

Herefore, it is necessary to convert the binary number to the sum of prime numbers 

输入

The input consists of several instances, each of them consisting of a single line. Each line of the input contains a 01 string, length of not more than 150.  The end of input is not marked in any special way.

输出

For each test case generate a single line containing a single integer , The sum of the primes.

样例输入

000010
0011
11001

样例输出

3
5
20

分析

根据题目意思,给的字符串的每个位置对应一个素数,而这些素数是按照从2开始的前150个素数,为了保证时间的最优,所以可以将这个素数数组定义好,后面输入字符串之后直接使用

代码

#include <algorithm>
#include <iostream>
#include <string>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
int prime[160]={0};
int isprime(int n)
{
    if(n==2)return 1;
    for(int i=2;i*i<=n;i++)
    {
        if(n%i==0) return 0;
    }
    return 1;
}
int main()
{
    int j=0;
    char s[160];
    for(int i=2;i<=1000;i++)
    {
        if(isprime(i)==1)
        {
            prime[j]=i;
            j++;
        }
    }//将从2开始的前160个素数存入数组
    while(scanf("%s",s)!=EOF)
    {
        int sum=0,j=0;
        for(int i=strlen(s)-1;i>=0;i--,j++)//字符串的倒序对应着素数数组的顺序
        {
            if(s[i]=='1')sum=sum+prime[j];//判断此位置素数对应的权值是否为1,为1则加入总和
        }
        printf("%d\n",sum);
    }
}


  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值