HDU 1390 Binary Numbers

Binary Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1778    Accepted Submission(s): 1121


Problem Description
Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0.


Example

The positions of 1's in the binary representation of 13 are 0, 2, 3.


Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.
 

Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
 

Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.
 

Sample Input
  
  
1 13
 

Sample Output
  
  
0 2 3
 

思路:这题就是找出一个数的二进制形式下1的位置,并输出。

AC代码:

#include<iostream>
using namespace std;
int main()
{
	int t,n,i,f;
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%d",&n);
			f=1;
			for(i=0;n!=0;i++)
			{
				if(n%2==1&&f==0)printf(" %d",i);
				if(n%2==1&&f==1){printf("%d",i);f=0;}
				n/=2;
			}
			printf("\n");
		}
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值