POJ-3258-River Hopscotch(二分+贪心)

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
Sample Input

25 5 2
2
14
11
21
17
Sample Output

4

这道题除了难想到二分外,最难的或许是看懂题目是要求什么.
这篇博客就是及时雨:http://m.blog.csdn.net/xp731574722/article/details/76099946
以下来自这篇博客的解释
二分答案。对最短距离进行二分,设为d,用pos记录上一个石头的位置,对石头遍历,如果第i个石头离pos的距离大于等于d,则说明这个石头无需移除,pos=a[i],如果第i个石头离pos的距离小于d,则说明这个石头必须移除,记录好移除石头的个数。遍历结束后,看被移除的石头个数是否小于等于M,如果是,则说明最短距离大于等于d,继续找更大的,如果不是,则找比d小的。

#include <cstdio>
#include <algorithm>
using namespace std;
int n;
int i[50005];
int erfen(int low,int high,int k)
{
    int cnt,last;
    int m;
    while(low<=high)
    {
        cnt=last=0;
        m=(low+high)/2;
        for(int a = 1; a <= n+1; a ++)
        {
            if(m>=i[a]-i[last])//看该点是不是可以去除
                cnt++;
            else
                last=a;
        }
        if(cnt>k)high=m-1;
        else low=m+1;
    }
    return low;
}
int main()
{
    int m,l;
    scanf("%d%d%d",&l,&n,&m);
    for(int a = 1; a <= n; a ++)
        scanf("%d",&i[a]);
    i[0]=0;
    i[n+1]=l;
    sort(i,i+n+1);
    printf("%d\n",erfen(0,l,m));
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值