Prim算法和Kruskal算法理解

一:Prim算法

Prim算法的实现就是通过搜索来实现的,首先找一个起始点a,然后找与起始点相关联的所有的点中离a最近的点b,并且把这个点融入最小生成树中,然后再比较与b相关联的点和与a相关联的点的距离,若可以更新点,则更新然后继续找!

拿一道poj的题来说

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. 
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
Input
The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. 
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i. 
Output
For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.
Sample Input
1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0
Sample Output
0
17
16
26
这个题就可一用到prim算法:代码如下
#include <iostream>
#include <vector>
#include<cstring> 
#include<cstdio> 
using namespace std;
const int maxn = 100 ;
const int INF = 0x3f3f3f3f;
int a , b , m ;
struct ac {
    int end , dis ;
};
int flag [ maxn ] ;///标记 
int dis[maxn]; 	//到生成树的距离 
vector<ac> q[maxn];//结构体存的是每个数据的重点和距离,可能多个 
int prim ( int i ){
    int res= 0 ;//最小值 
    memset(flag, 0, sizeof(flag));
    memset(dis, INF, sizeof(dis));//初始化数组 
    dis[i]=0;//记录i到生成树的距离 
    for ( int i = 0 ; i < a ; i ++ ) {//开始循环遍历了 
        int u = -1 , min = INF ;//用u来记录点的变化,min找最小值 
        for ( int j = 1 ; j <= a ; j ++ ) {//21-26找下一个离生成树最近的点 
            if ( !flag[j] && dis [ j ] < min ) {
                u = j ;
                min = dis [ u ]; 
            }
        }
        res += min ;//求和 
        flag[u]=1;//标记 
        //更新点到树的距离 ,q[u]相当于一个结构体数组 
        for ( int i = 0 ; i < q[u].size(); i ++ ) {
            int v = q[u][i].end;//v表示所有相邻的点 
            if ( !flag[v]&& q[u][i].dis<dis[v]){//看能不能更换距离 
                dis[v]=q[u][i].dis ;
            }
        }
    }
    return res ;
}
int main()
{
    while (scanf("%d" , &a ) , a) {
        cin >> m ;
        b = m ;
        while ( b -- ) {
            ac p ;
            int a ;
            cin >> a ;
            cin >>p.end>>p.dis;
            q[a].push_back(p);//无向图,要存两遍 
            int t = p.end ;
            p.end=a;
            q[t].push_back(p);
        }
        char x , y ;
        scanf ( "%c%c" ,&x ,&y ) ;
        int t = prim ( 1 ) ;//开始遍历 
        cout << t<<endl;
        for( int i= 1 ; i <= a ; i ++ ) {
        	q[i].clear();
		}
    }
    return 0;
}
当然也可以用Kruska

代码如下

#include <iostream>
#include <algorithm>
#include<cstdio>
#include<cstdio>
using namespace std;
const int maxn = 110 ;
struct ac {
    int begin ;
    int end ;
    int jl ;
};
ac q[1000];
int fa[maxn];
int k ;
int find ( int x )
{
    int r = x ;
    while ( r != fa[r] ) {
        r = fa[ r ];
    }
    return r ;
}
void join ( int x , int y ) {
    int xx = find ( x ) , yy = find ( y ) ;
    if ( xx != yy ) {
        fa [xx] = yy ;
    }
}
bool cmp ( ac a , ac b ) {
    return a.jl < b.jl ;
}
int ans ;
void kus(){
    sort ( q , q + k , cmp ) ;
    for ( int i = 0 ; i < k ; i ++ ) {
        if  ( find(q[i].begin) != find ( q[i].end )){
            join ( q[i].begin , q[i].end );
            ans += q[i].jl;

        }
    }
    cout << ans << endl;
}
int main ()
{
    int n ;
    while ( scanf("%d" , &n ) , n ) {
        k = 0 ;
        memset(q, 0, sizeof(q));
        while ( n -- ) {
            int a , b , c ;
		    cin >> a >> b >> c ;
            q[k].begin=a;
            q[k].end=b;
            q[k].jl=c;
            k ++ ;
        }
        for ( int i = 1 ; i <= n ; i ++ ) {
            fa[i]=i ;
        }
        ans = 0 ;
        kus();
    }
    return 0;
}






  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值