HDU3768限制最短路(有必经过的点)

Shopping

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 519    Accepted Submission(s): 172


Problem Description
You have just moved into a new apartment and have a long list of items you need to buy. Unfortunately, to buy this many items requires going to many different stores. You would like to minimize the amount of driving necessary to buy all the items you need.

Your city is organized as a set of intersections connected by roads. Your house and every store is located at some intersection. Your task is to find the shortest route that begins at your house, visits all the stores that you need to shop at, and returns to your house.
 

Input
The first line of input contains a single integer, the number of test cases to follow. Each test case begins with a line containing two integers N and M, the number of intersections and roads in the city, respectively. Each of these integers is between 1 and 100000, inclusive. The intersections are numbered from 0 to N-1. Your house is at the intersection numbered 0. M lines follow, each containing three integers X, Y, and D, indicating that the intersections X and Y are connected by a bidirectional road of length D. The following line contains a single integer S, the number of stores you need to visit, which is between 1 and ten, inclusive. The subsequent S lines each contain one integer indicating the intersection at which each store is located. It is possible to reach all of the stores from your house.
 

Output
For each test case, output a line containing a single integer, the length of the shortest possible shopping trip from your house, visiting all the stores, and returning to your house.
 

Sample Input
  
  
1 4 6 0 1 1 1 2 1 2 3 1 3 0 1 0 2 5 1 3 5 3 1 2 3
 

Sample Output
  
  
4
 

Source
 



思路:求必经过的点到各点的最短距离,然后枚举这些点的全排列得到最优解



//最短路必经过的点 点数在10以内

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<queue>
#define INF 99999999
#define min(a,b) (a<b?a:b)
using namespace std;

const int MAXN=100010;

int n,m; //点数和边数
int cnt;// 前向星中的边数
int k; // 必经过的点的点数
int shop[12]; //必经过的点的集合
int dis[12][MAXN];  // 必经过的点到各点的距离
int head[MAXN]; //	前向星的头部
int fg[MAXN];  //离散化必经过的点
struct Ed
{
	int v,w,next;
}e[MAXN*2];

void addEd(int u,int v,int w)
{
	e[cnt].v=v;
	e[cnt].w=w;
	e[cnt].next=head[u];
	head[u]=cnt++;
}



void spfa(int s0,int s)
{
	queue<int>Q;
	int i,u;
	int f[MAXN];
	for(i=0;i<n;i++)
	{
		dis[s][i]=INF;
		f[i]=0;
	}
	dis[s][s0]=0;
	Q.push(s0);

	while(!Q.empty())
	{
		u=Q.front();
		Q.pop();
		f[u]=0;
		for(i=head[u];i!=-1;i=e[i].next)
		{
			if(dis[s][u]+e[i].w<dis[s][e[i].v])
			{
				dis[s][e[i].v]=dis[s][u]+e[i].w;
				f[e[i].v]=1;
				Q.push(e[i].v);
			}
		}
	}
}

void solve()
{
	int i,sum=INF,ans;
	do
	{
		ans=dis[fg[shop[0]]][0];
		for(i=1;i<k;i++)
			ans+=dis[fg[shop[i-1]]][shop[i]];
		ans+=dis[fg[shop[i-1]]][0];
		sum=min(sum,ans);
	}while(next_permutation(shop,shop+k));

	printf("%d\n",sum);
}




void input()
{
	int i,u,v,w,T;
	scanf("%d",&T);
	while(T--)
	{
		cnt=0;
		memset(head,-1,sizeof(head));
		scanf("%d%d",&n,&m);
		for(i=0;i<m;i++)
		{
			scanf("%d %d %d",&u,&v,&w);
			addEd(u,v,w);
			addEd(v,u,w);
		}
		scanf("%d",&k);
		for(i=0;i<k;i++)
		{
			scanf("%d",&shop[i]);
			fg[shop[i]]=i;
			spfa(shop[i],i);
		}
		sort(shop,shop+k);
		solve();
	}
}


int main()
{
	input();
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值