HDU4883 TIANKENG’s restaurant(贪心)

题目:

TIANKENG’s restaurant

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 3054    Accepted Submission(s): 1124


Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input
  
  
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output
  
  
11 6
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6018  6017  6016  6015  6014 
 

Statistic |  Submit |  Discuss |  Note
思路:

昨晚比赛的时候,这道题一看就是个贪心题,于是我就按照普通的贪心做,按照结束时间排了序,然后判断开始时间和结束时间的大小,最后一直WA,百思不得其解。最后明白了,选到这个时间段的时候凳子的数量并不是只与前一个有关系,其实与后面的也有关,最后还剩10分钟才A。。思维考虑还是不全面啊


本题给了t组数据,然后有n个时间段,然后有两行,每行给了凳子的数量和开始和结束时间,求最少的凳子数量。做的时候直接把时间点换成一个整数,排序,然后用数组存一下当前时间段的最大的,最后遍历一遍找出最大的就好


代码:

#include <stdio.h>
#include <string.h>
#include <string>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define N 10000+20
#define M 2000+10
#define LL long long
using namespace std;
struct node
{
    int num,start,end;
} zz[N];//记录凳子的数量,开始和结束的时间
int sum[N];
bool cmp(node a,node b)
{
    if(a.start==b.start)
        return a.end<b.end;
    else
        return a.start<b.start;//按照开始时间从前到后排序
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        mem(sum,0);
        int n;
        scanf("%d",&n);
        int num,a1,a2,b1,b2;
        for(int i=0; i<n; i++)
        {
            scanf("%d %d:%d %d:%d",&num,&a1,&a2,&b1,&b2);
            zz[i].num=num;
            zz[i].start=a1*100+a2;//把时间转换成容易表示的值
            zz[i].end=b1*100+b2;
            for(int j=zz[i].start; j<zz[i].end; j++)
                sum[j]+=zz[i].num;
        }
        int maxx=0;
        for(int i=0; i<=M; i++)
            maxx=max(sum[i],maxx);//找出里面最大的
        printf("%d\n",maxx);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值