HDU—4883TIANKENG’s restaurant

TIANKENG’s restaurant

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 684    Accepted Submission(s): 326


 

Problem Description

TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?

 

Input

The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.

 

Output

For each test case, output the minimum number of chair that TIANKENG needs to prepare.

 

Sample Input

2

2

6 08:00 09:00

5 08:59 09:59

2

6 08:00 09:00

5 09:00 10:00

 

Sample Output

11

6

 

做题思路: 

模拟数组,统一单位将小时化成分钟变数组脚标,来人时存开始,人走存结束,如 w[s]=6, a[e] = - 6;然后遍历相加,得出最大值。

思路解释:人离开就会多出来对应的n1个空凳子。

  如果下次来的 人在上次来的人时间之后,且需要的凳子n2多于上次的n1,那么它就会先用上次 的n1然后再需准备n2-n1个,那么需要准备的凳子总和sumn为上次的n1+(n2-n1)即为n2,。
  如果下次来的 人在上次来的人时间之后,且需要的凳子n2少于上次的n1,那么再需要准备的凳子为0, 要准备的凳子总和sumn=n1(且n1中还多于的凳子以后用或者不用都可以)

AC代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
const int N=1447;
int t,m,n,w[N],a,b,c,d;
int main()
{
	scanf("%d",&t);
	while(t--)
	{
		memset(w,0,sizeof(w));
		int Begin=0x3f3f3f,End=-0x3f3f3f,ans=-0x3f3f3f,sum=0;
		scanf("%d",&m);
		for(int q=1;q<=m;q++)
		{
			scanf("%d %d:%d %d:%d",&n,&a,&b,&c,&d);
			w[a*60+b]+=n;
			w[c*60+d]+=-n;
			if(a*60+b<Begin)  Begin=a*60+b;
			if(c*60+d>End)  End=c*60+d;	
		}
		for(int i=Begin;i<=End;i++)
		{
			sum+=w[i];
			if(sum>ans)
			ans=sum;
		}
		printf("%d\n",ans);
	}
	return 0;
}

 

 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值