HDU4027 Can you answer these queries?(线段树区间更新,区间开根号)

题目:

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 17754    Accepted Submission(s): 4163


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
  
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
  
  
Case #1: 19 7 6
 

Source
 

思路:

题目先给了一段区间,然后给了m组询问,0代表把a~b这个区间的每个值变成它的平方根,1代表查询a~b这个区间的和。

这个题容易超时,我们应该知道,一个数开平方开上几次后肯定会变成1,所以我们需要加上一句判断,判断当前要更新的节点的和是否等于他左右区间的差,如果等于,那就证明这一段区间都是1,已经不用再更新了,剩下的就是普通的线段树了


代码:

#include <cstdio>
#include <cstring>
#include <cctype>
#include <string>
#include <set>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define N 101000
#define ll long long
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
ll sum[N<<2];
void pushup(ll rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(ll l,ll r,ll rt)
{
	if(l==r)
	{
		scanf("%lld",&sum[rt]);
		return;
	}
	ll m=(l+r)>>1;
	build(lson);
	build(rson);
	pushup(rt);
}
void update(ll L,ll R,ll l,ll r,ll rt)
{
	if(sum[rt]==r-l+1) return;//排除整个区间是1的情况
	if(l==r)
	{
		sum[rt]=(ll)(sqrt(sum[rt]));
		return;
	}
	ll m=(l+r)>>1;
	if(L<=m) update(L,R,lson);
	if(m<R) update(L,R,rson);
	pushup(rt);
}
ll query(ll L,ll R,ll l,ll r,ll rt)
{
	if(L<=l&&r<=R)
		return sum[rt];
	ll m=(l+r)>>1;
	ll ans=0;
	if(L<=m)
		ans+=query(L,R,lson);
	if(R>m)
		ans+=query(L,R,rson);
	return ans;
}
int main()
{
	ll n,q=1,a,b,m,x;
	while(~scanf("%lld",&n))
	{
		printf("Case #%lld:\n",q++);
		build(1,n,1);
		scanf("%lld",&m);
		while(m--)
		{
			scanf("%lld%lld%lld",&x,&a,&b);
			if(a>b)swap(a,b);
			if(x==0)
				update(a,b,1,n,1);
			if(x==1)
				printf("%lld\n",query(a,b,1,n,1));
		}
		puts("");
	}
	return 0;
}


2017年12月02日09:18:38  重写

#include <cstdio>
#include <cstring>
#include <cctype>
#include <string>
#include <set>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const ll N=100000+20;
ll sum[N<<2];
ll flag[N<<2];
void pushup(ll rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
    flag[rt]=flag[rt<<1]&flag[rt<<1|1];
}
void build(ll l,ll r,ll rt)
{
    if(l==r)
    {
        scanf("%lld",&sum[rt]);
        if(sum[rt]<=1)flag[rt]=1;
        return;
    }
    ll m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}
void update(ll a,ll b,ll l,ll r,ll rt)
{
    if(flag[rt]==1) return;
    if(l==r)
    {
        sum[rt]=floor(sqrt(sum[rt]));
        if(sum[rt]<=1)flag[rt]=1;
        return;
    }
    ll m=(l+r)>>1;
    if(a<=m)
        update(a,b,lson);
    if(b>m)
        update(a,b,rson);
    pushup(rt);
}
ll query(ll L,ll R,ll l,ll r,ll rt)
{
    if(L<=l&&r<=R)
        return sum[rt];
    ll m=(l+r)>>1;
    ll ans=0;
    if(L<=m)
        ans+=query(L,R,lson);
    if(R>m)
        ans+=query(L,R,rson);
    return ans;
}
int main()
{
    ll n,m;
    ll q=1,a,b,x;
    while(~scanf("%lld",&n))
    {
        mem(flag,0);
        printf("Case #%lld:\n",q++);
        build(1,n,1);
        scanf("%lld",&m);
        while(m--)
        {
            scanf("%lld%lld%lld",&x,&a,&b);
            if(a>b)swap(a,b);
            if(x==1)
                printf("%lld\n",query(a,b,1,n,1));
            else if(x==0)
                update(a,b,1,n,1);
        }
        puts("");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值