HDU 1018 Big Number

Big Number

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33542    Accepted Submission(s): 15823

Problem Description

In many applications verylarge integers numbers are required. Some of these applications are using keysfor secure transmission of data, encryption, etc. In this problem you are givena number, you have to determine the number of digits in the factorial of thenumber.

 

 

Input

Input consists of several linesof integer numbers. The first line contains an integer n, which is the numberof cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107on each line.

 

 

Output

The output contains the numberof digits in the factorial of the integers appearing in the input.

 

 

Sample Input

2

10

20

 

 

Sample Output

7

19

 

题目大概要义 


Big Number

给你一个数,求出N的阶乘是由多少位组成的。

例如

输入:

2

10

20

 

输出:

7

19

 

AC代码

#include<stdio.h>
#include<math.h>
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF&&n)
	{
		while(n--)
		{
			int a;
			int t=1;
			double count=0;
			scanf("%d",&a);
		 	for(int i=1;i<=a;i++)
		 	{
	 			count+=log10(i);
	 		}
		 	printf("%d\n",(int)count+1);
		}
		return 0;
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值