HDU 1019 Least Common Multiple

Least CommonMultiple

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44190    Accepted Submission(s): 16580

Problem Description

The least common multiple (LCM) of a set of positive integers is thesmallest positive integer which is divisible by all the numbers in the set. Forexample, the LCM of 5, 7 and 15 is 105.

 

 

Input

Input will consist of multipleproblem instances. The first line of the input will contain a single integer indicatingthe number of problem instances. Each instance will consist of a single line ofthe form m n1 n2 n3 ... nm where m is the number of integers in the set and n1... nm are the integers. All integers will be positive and lie within the rangeof a 32-bit integer.

 

 

Output

For each problem instance,output a single line containing the corresponding LCM. All results will lie inthe range of a 32-bit integer.

 

 

Sample Input

2

3 5 7 15

6 4 10296 936 1287 792 1

 

 

Sample Output

105

10296

 


题目就是求最小公倍数,每次输入一个数后都记录下当前最小公倍数,虽然一次AC,但是运行用时多,以后多做改进


#include<stdio.h>
int main()
{
	int n,m,a,k;
	while(scanf("%d",&n)!=EOF&&n)
	{
		while(n--)
		{
			scanf("%d",&m);
			int t=1;
			while(m--)
			{
				int i=2;
				scanf("%d",&a);
				k=a;			//记录下a的原值 
				while(a%t!=0)	//求出最小公倍数 
				{
					a=k*i;
					i++;
				} 
				t=a;			//记录下当前最小公倍数a 
			}
			printf("%d\n",a);
		}
		return 0;
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值