poj 2411(压缩dp)

Mondriaan's Dream
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 14212 Accepted: 8202

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205


题目链接:http://poj.org/problem?id=2411
题意:
    给定一个矩形,边长小于或等于11,用1*2的矩形方块填满,问有多少种填法。
算法分析:
    一般看到求方法数一般都是dp;
    可状态转移的方式不好储存,同一行填满有多种方式,每种方式对应的下一行的填补方式都不一样。
   由此,我们必需用一种方式去将每行的状态记录下来。
   此时,就可以考虑二进制了。
   二进制的每一位代表此处相应的地方状态。
   可以枚举任意两行的关系。
  
void dfs(int l,int pre,int now)
{
    if(l>a)return ;
    if(l==a)
    {
        t[cnt][0]=pre;
        t[cnt++][1]=now;
        return ;
    }
    dfs(l+2,(now<<2)|3,(pre<<2)|3);
    dfs(l+1,(now<<1)|1,pre<<1);
    dfs(l+1,now<<1,(pre<<1)|1);
}
由此就可以进行递推关系,由上一行递推下一行
     dp[0][(1<<a)-1]=1;
        for(int i=0;i<b;i++)
        {
            for(int j=0;j<cnt;j++)
                dp[i+1][t[j][1]]+=dp[i][t[j][0]];
        }

源代码:
#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=20;
typedef long long ll;
ll dp[maxn][1<<13],t[1<<15][2];
int a,b,cnt;
void dfs(int l,int pre,int now)
{
    if(l>a)return ;
    if(l==a)
    {
        t[cnt][0]=pre;
        t[cnt++][1]=now;
        return ;
    }
    dfs(l+2,(now<<2)|3,(pre<<2)|3);
    dfs(l+1,(now<<1)|1,pre<<1);
    dfs(l+1,now<<1,(pre<<1)|1);
}
int main()
{
    while(scanf("%d%d",&a,&b)!=EOF&&(a+b))
    {
        if(a>b)
            swap(a,b);
        cnt=0;
        dfs(0,0,0);
        memset(dp,0,sizeof(dp));
        dp[0][(1<<a)-1]=1;
        for(int i=0;i<b;i++)
        {
            for(int j=0;j<cnt;j++)
                dp[i+1][t[j][1]]+=dp[i][t[j][0]];
        }
        ll ans=0;
        printf("%lld\n",dp[b][(1<<a)-1]);
    }
    return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值