Cooking Competition

"Miss Kobayashi's Dragon Maid" is a Japanese manga series written and illustrated by Coolkyoushinja. An anime television series produced by Kyoto Animation aired in Japan between January and April 2017.


In episode 8, two main characters, Kobayashi and Tohru, challenged each other to a cook-off to decide who would make a lunchbox for Kanna's field trip. In order to decide who is the winner, they asked n people to taste their food, and changed their scores according to the feedback given by those people.


There are only four types of feedback. The types of feedback and the changes of score are given in the following table.


Type Feedback Score Change
(Kobayashi) Score Change
(Tohru)
1 Kobayashi cooks better +1 0
2 Tohru cooks better 0 +1
3 Both of them are good at cooking +1 +1
4 Both of them are bad at cooking -1 -1
Given the types of the feedback of these n people, can you find out the winner of the cooking competition (given that the initial score of Kobayashi and Tohru are both 0)?


Input


There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 100), indicating the number of test cases. For each test case:


The first line contains an integer n (1 ≤ n ≤ 20), its meaning is shown above.


The next line contains n integers a1, a2, ... , an (1 ≤ ai ≤ 4), indicating the types of the feedback given by these n people.


Output


For each test case output one line. If Kobayashi gets a higher score, output "Kobayashi" (without the quotes). If Tohru gets a higher score, output "Tohru" (without the quotes). If Kobayashi's score is equal to that of Tohru's, output "Draw" (without the quotes).


Sample Input


2
3
1 2 1
2
3 4
Sample Output


Kobayashi
Draw
Hint


For the first test case, Kobayashi gets 1 + 0 + 1 = 2 points, while Tohru gets 0 + 1 + 0 = 1 point. So the winner is Kobayashi.


For the second test case, Kobayashi gets 1 - 1 = 0 point, while Tohru gets 1 - 1 = 0 point. So it's a draw.

解题思路:

水题。。

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int t,n,m,i;
	cin>>t;
	while(t--)
	{
		cin>>n;
		int a=0,b=0;
		for(i=0;i<n;i++)
		{
			cin>>m;
			if(m==1)
			{
				a++;
			}
			else if(m==2)
			{
				b++;
			}
			else if(m==3)
			{
				a++;
				b++;
			}
			else
			{
				a--;
				b--;
			}
			
		}
		if(a>b)
				cout<<"Kobayashi"<<endl;
			else if(a<b)
				cout<<"Tohru"<<endl;
			else
				cout<<"Draw"<<endl;
	}
	
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值