Currency Exchange--(最短路径算法)

Currency Exchange

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 74   Accepted Submission(s) : 19
Problem Description
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 
 

Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10<sup>3</sup>. <br>For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10<sup>-2</sup><=rate<=10<sup>2</sup>, 0<=commission<=10<sup>2</sup>. <br>Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10<sup>4</sup>. <br>
 

Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
 

Sample Input
  
  
3 2 1 20.0 1 2 1.00 1.00 1.00 1.00 2 3 1.10 1.00 1.10 1.00
 

Sample Output
  
  
YES

用Bellman算法若能求出一个正权回路,那么货币经转化会越来越大

代码(Bellman-Ford):

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
using namespace std;
struct node{
    int a,b;
    double r,c;
}p[205];
int n,m,s;
double v,dis[105];
int main()
{
    int i,j,a,b;
    double r1,c1,r2,c2;
    scanf("%d%d%d%lf",&n,&m,&s,&v);
    for(i=1;i<=m;i++)  //n个exchange point化为2*m个边
    {
        scanf("%d%d%lf%lf%lf%lf",&a,&b,&r1,&c1,&r2,&c2);
        p[i].a=a; p[i].b=b; p[i].r=r1; p[i].c=c1;
        p[i+m].a=b; p[i+m].b=a; p[i+m].r=r2; p[i+m].c=c2;
    }
    for(i=1;i<=n-1;i++)
        dis[i]=0;
    dis[s]=v;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=2*m;j++)
        {
            double w=(dis[p[j].a]-p[j].c)*p[j].r;
            if(w>dis[p[j].b]) {dis[p[j].b]=w;}
        }
    }
    bool flag=false;
    for(i=1;i<=2*m;i++)
    {
        double w=(dis[p[i].a]-p[i].c)*p[i].r;
        if(w>dis[p[i].b]) {flag=true; break;}  //存在正权回路
    }
    if(flag) printf("YES\n");
    else printf("NO\n");
    return 0;
}

参考:http://blog.csdn.net/lyhvoyage/article/details/19281013

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Vue Currency Filter 是一个用于格式化货币的 Vue.js 插件。它可以帮助你在 Vue 应用中轻松地格式化货币金额,并提供一些选项来自定义格式。 你可以使用 Vue Currency Filter 插件来格式化货币金额的显示,例如将金额转换为指定的货币符号、千位分隔符和小数位数等。这可以在处理金融相关的应用或电子商务平台中非常有用。 要使用 Vue Currency Filter 插件,你需要先安装它。可以通过 npm 或 yarn 来安装,具体的安装命令如下: ```bash npm install vue-currency-filter ``` 或者 ```bash yarn add vue-currency-filter ``` 安装完成后,在你的 Vue 应用中引入并使用该插件。你可以在主入口文件(通常是 main.js)中添加以下代码: ```javascript import Vue from 'vue' import VueCurrencyFilter from 'vue-currency-filter' Vue.use(VueCurrencyFilter) ``` 然后,你就可以在组件中使用 `currency` 过滤器来格式化货币金额了。例如,你可以这样使用: ```html <span>{{ amount | currency }}</span> ``` 其中 `amount` 是一个表示金额的变量。 除了默认的格式化选项外,Vue Currency Filter 还允许你传递一些参数来自定义格式。例如,如果你想将金额格式化为美元,并保留两位小数,可以这样使用: ```html <span>{{ amount | currency('USD', 2) }}</span> ``` 这样,`amount` 变量将以美元的货币符号进行显示,并且小数部分将保留两位。 希望这能帮助到你使用 Vue Currency Filter 插件来格式化货币金额。如果你有更多问题,可以继续提问!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值