hdu Max Sum Plus Plus(最大m段子段和)

1、http://acm.hdu.edu.cn/showproblem.php?pid=1024

2、题目大意:

已知有n个数,求m段不相交的子段权值之和最大,

状态转移方程:dp[i][j]表示以i为结尾元素的j个子段的数和

dp[i][j]=max(dp[i-1][j]+a[i],dp[i-k][j-1]+a[i]);其中(j-1<=k<=n-m+1)

此题实现这种思想:

for(i=1;i<=m;i++)
        {
             maxx=(-1)*(N*90);//初始化
            for(j=i;j<=n;j++)
            {
                now[j]=max(now[j-1]+a[j],pre[j-1]+a[j]);//其中now[j-1]表示的是以j-1结尾的元素i个子段的数和,pre[j-1]表示的是前j-1个元素中i-1个子段的数和
                pre[j-1]=maxx;//放在此处是为了实现pre[j-1]+a[j]中a[j]是一个独立的子段,那么此时就应该用的是i-1段
                if(now[j]>maxx)
                {
                    maxx=now[j];
                }
            }
        }

3、题目:

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11549    Accepted Submission(s): 3807


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^


 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.


 

Output
Output the maximal summation described above in one line.


 

Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3


 

Sample Output
  
  
6 8

 

4、代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>
#define N 1000
int a[N+5];
int now[N+5];
int pre[N+5];
using namespace std;
int main()
{
    int n,m,maxx,i,j;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        for(i=1;i<=n;i++)
        scanf("%d",&a[i]);
        memset(now,0,sizeof(now));
        memset(pre,0,sizeof(pre));
        for(i=1;i<=m;i++)
        {
             maxx=(-1)*(N*90);
            for(j=i;j<=n;j++)
            {
                now[j]=max(now[j-1]+a[j],pre[j-1]+a[j]);
                pre[j-1]=maxx;
                if(now[j]>maxx)
                {
                    maxx=now[j];
                }
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}


 

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值