Max Sum(最大连续子序列的和)

Max Sum(最大连续子序列的和)

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

题目大意:求出一串数字中和最大的字串 找出字串的起始位置和终止位置
注意: 起始位置不一定是1!!!
思路:dp,双层for循环必超时,对于一个数来说,如果该数>0,那么加上它后sum是增大的,max更新,但如果该数<0,sum减小,max不变,直到sum<0,他应该重新规定起始位置,即下一个位置;在全为负数的情况下,max应为最大的那个负数,同理,对于一个数来说是这样,那么对于多个数组成的子序列来说也是这样。这个题我是感觉有点难理解,可能还是对dp不太了解吧
AC代码:

#include<stdio.h>
#include<string.h>
int a[110000];
int main()
{
	int t,i,j,k,n,z=0,s,e;
	scanf("%d",&t);
	while(t--)
	{
		z++;
		int maxx=-999999,sum=0;
		memset(a,0,sizeof(a));
		scanf("%d",&n);
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		int head=1;
		for(i=1;i<=n;i++)
		{
			sum=sum+a[i];//求当前和
			if(sum>maxx)//如果sum>maxx,就更新maxx,起始位置和结束位置
			{
				maxx=sum;
				s=head;//定义head为1,因为此时起始位置为1
				e=i;//s为起始位置,e为结束位置
			}
			if(sum<0)
			{
				sum=0;
				head=i+1;//sum<0,要重新规定起始位置,即i+1
			}
		}
		printf("Case %d:\n",z);
		printf("%d %d %d\n",maxx,s,e);
		if(t)//格式控制
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值