HDU 1004 C语言

HDU 1004
Let the Balloon Rise


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 122766    Accepted Submission(s): 48349




Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.


This year, they decide to leave this lovely job to you. 
 


Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.


A test case with N = 0 terminates the input and this test case is not to be processed.
 


Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 


Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
 


Sample Output
red
pink
 


Author
WU, Jiazhi
 


Source
ZJCPC2004


代码如下:
#include<stdio.h>
#include<string.h>
int main(void)
{
char color[1000][16];
int n,i,j,number[1000],max,k;
while((scanf("%d",&n)) && n!=0)
{
for(i=0;i<n;i++)
{
scanf("%s",&color[i]);
}
for(i=0;i<n;i++)
{
number[i]=0;
}
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
       if(strcmp(color[i],color[j])==0) number[i]+=1;
}
}
max=0;
k=0;
for(i=0;i<n;i++)
{
if(number[i]>max)
{
                             max=number[i];
            k=i;
}
}
printf("%s\n",color[k]);
}
return 0;
}


总结:这是一道很简单的数组的应用题,使用二位数组来储存颜色,编辑时一定要细心,否则很容易在简单的问题上面出错,得不偿失。
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值