hdu 1004 (Let the balloon rise) c、c++


hdu 1004(Let the balloon rise)


题目http://acm.hdu.edu.cn/showproblem.php?pid=1004
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5 green red blue red red 3 pink orange pink 0

Sample Output
red pink
分析:要求输入数字(0 < N <= 1000),和对应数字的颜色,返回输入次数最多的颜色
思路:1. 把输入传入char ball[1001][16]中,并建立int num[1001],存储每个输入的颜色重复的个数,最后print num最大的ball
2. 利用c++中的map,在每个颜色后记录输入的次数

c语言


    //
    //  main.c
    //  hdu1004
    //
    //  Created by zhan_even on 2018/10/18.
    //  Copyright © 2018年 zhan_even. All rights reserved.
    //
    #include<stdio.h>
    #include<string.h>
    int main()
    {
        int i,j,pos,max,n;
        int num[1001];
        char  ball[1001][16];
        while (scanf("%d",&n)==1&&n)
        {
            scanf("%s",ball[0]);
            num[0]=1;
            for (i=1;i<n;i++)
            {
                scanf("%s",ball[i]);
                num[i]=1;
                for  (j=0;j<i;j++)
                {
                    if (strcmp(ball[i],ball[j])==0)
                    {
                        num[i]++;
                    }
                }
            }
            pos=0;
            max=0;
            for (i=0;i<n;i++)
            {
                if (num[i]>max)
                {
                    max=num[i];
                    pos=i;
                }
                
            }
            printf("%s\n",ball[pos]);
        }
        return 0;
    }

 


c++:

//
//  main.cpp
//  hdu1004mp
//
//  Created by zhan_even on 2018/10/19.
//  Copyright © 2018年 zhan_even. All rights reserved.
//

#include <iostream>
#include <map>
#include <string>

using namespace std;

int main(void) {
    map<string, int> ball;
    int n;
    string color, max_color;

    while (cin >> n&&n) {
        ball.clear();
        while (n--) {
            cin >> color;
            ball[color]++;
        }
        map<string,int>::iterator iter;
        int max = 0;
        for(iter = ball.begin(); iter != ball.end(); iter++){
            if(iter -> second > max){
                max = iter -> second;
                max_color = iter -> first;
            }
        }
        cout << max_color <<endl;
        
    }
    
    return 0;
}

收获:一开始使用c语言编程,思路简单,但是在在写出之后上网搜索发现还可以用map的方法,顺便了解了一下C++的编程规范,学习了一下基本的map的运用。

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值