acm之搜索题目1

Problem Description

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

Input

The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.

Output

There should be one line per test case containing the length of the largest string found.

Sample Input

2
3
ABCD
BCDFF
BRCD
2
rose
orchid

Sample Output

2
2

代码:
#include <stdio.h>
#include <string.h>
int main()
{
    char string[105][105],str[105],pos[105],inv[105];
    int i,j,t,n,min_len,index;
    int flag;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        min_len = 105;
        for(i = 0; i < n; i++)
        {
            scanf("%s",string[i]);
            if(strlen(string[i])<min_len)
            {
                min_len = strlen(string[i]);
                index = i;
            }
        }
        int len;
        len = min_len;
        strcpy(str,string[index]);
        while(len>0)
        {
            flag = 0;
            for(i = 0; i <= min_len-len;i++)
            {
                flag = 1;
                strncpy(pos,str+i,len);
                for(j = 0;j<len;j++)
                inv[j] = pos[len-j-1];
                pos[len] = inv[len] ='\0';
                for(j = 0;j<n;j++)
                {
                    if(strstr(string[j],pos)==NULL
                   &&strstr(string[j],inv)==NULL)                                              
                    {
                        flag = 0;
                        break;
                    }
                }
                if(flag)break;
            }
            if(flag)break;
            len--;
        }
        printf("%d\n",len);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值