lightoj1044--Palindrome Partitioning(记忆化搜索)

Description

A palindrome partition is the partitioning of a string such that each separate substring is a palindrome.

For example, the string "ABACABA" could be partitioned in several different ways, such as {"A","B","A","C","A","B","A"}, {"A","BACAB","A"}, {"ABA","C","ABA"}, or {"ABACABA"}, among others.

You are given a string s. Return the minimum possible number of substrings in a palindrome partition of s.

Input

Input starts with an integer T (≤ 40), denoting the number of test cases.

Each case begins with a non-empty string s of uppercase letters with length no more than 1000.

Output

For each case of input you have to print the case number and the desired result.

Sample Input

3

AAAA

ABCDEFGH

QWERTYTREWQWERT

Sample Output

Case 1: 1

Case 2: 8

Case 3: 5


题意:给你一个字符串,让你找出回文串的最少个数

思路:这是一道动态规划,将一条字符串切割成两条(或者不切割),判断两条子串符合条件的值的和的最小值

优化思路:先给字符串的回文子串打表ok[i][j],在切割的同时判断右半边是否是回文的,是则d[i]=min(d[i],1+d[i-j]),不是说明这种情况必定不是最优

递归代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
using namespace std;
typedef long long ll;
string a;
int d[1005][1005];
int ok[1005][1005];
int dp(int l,int r)
{
    if(d[l][r]>=0)return d[l][r];
    if(ok[l][r])return d[l][r]=1;
    int minn=1001;
    for(int i=l; i<r; i++)
        if(ok[l][i])
        minn=min(minn,1+dp(i+1,r));
    return d[l][r]=minn;
}
int main()
{
    int t,fir=1;
    cin>>t;
    while(t--)
    {
        cin>>a;
        memset(d,-1,sizeof(d));
        memset(ok,0,sizeof(ok));
        int n=a.length();
        for(int i=0; i<n; i++)ok[i][i]=1;
        for(int i=0; i<n-1; i++)ok[i][i+1]=(a[i]==a[i+1]);
        for(int len=3; len<=n; len++)
            for(int i=0; i+len-1<n; i++)
            {
                int j=i+len-1;
                ok[i][j]=(a[i]==a[j])&&ok[i+1][j-1];
            }
        printf("Case %d: %d\n",fir++,dp(0,n-1));
    }
    return 0;
}

非递归代码:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
using namespace std;
typedef long long ll;
string a;
int d[1005];
int ok[1005][1005];
int main()
{
    int t,fir=1;
    cin>>t;
    while(t--)
    {
        cin>>a;
        memset(ok,0,sizeof(ok));
        int n=a.length();
        for(int i=0; i<n; i++)ok[i][i]=1;
        for(int i=0; i<n-1; i++)ok[i][i+1]=(a[i]==a[i+1]);
        for(int len=3; len<=n; len++)
            for(int i=0; i+len-1<n; i++)
            {
                int j=i+len-1;
                ok[i][j]=(a[i]==a[j])&&ok[i+1][j-1];
            }
        for(int i=0; i<n; i++)
        {
            d[i]=i+1;
            for(int j=0; j<=i; j++)
                if(ok[j][i])
                {
                    if(j==0)
                        d[i]=1;
                    else
                        d[i]=min(d[i],1+d[j-1]);
                }
        }
        printf("Case %d: %d\n",fir++,d[n-1]);
    }
    return 0;
}




Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值