hdu 1325 is it a tree? 5.1.3

愉快的水题

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 123 Accepted Submission(s): 62
 
Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
 
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 
Output

            For each test case display the line ``Case k is a tree.\\\\\\\" or the line ``Case k is not a tree.\\\\\\\", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
 
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
 

看起来要判断方向好像很玄幻,实际上只要判断每次输入的一对数中第二个数是不是根即可。这也能算并查集么……

#include <iostream>
#define m 100001
using namespace std;
int a,b,flag;
int set[m];
int v[m];
int i;
int main()
{
    int count=1;
    while(cin>>a>>b)
    {
        if(a<0&&b<0)
        {break;}
        flag=0;
        for(i=1;i<m;i++)
        {
            set[i]=0;
            v[i]=0;
        }
        int e=0;
        while(a&&b)
        {
            if(!v[a])
            {
                v[a]=1;
                e++;
            }
            if(!v[b])
            {
                v[b]=1;
                e++;
            }
            e--;
            if(set[b]==0)//b is root
            {
                set[b]=1;
            }
            else
            {
                flag=1;
                break;
            }
            cin>>a>>b;
        }
        while(a && b) { scanf("%d %d",&a,&b);} 
        if(!flag&&e==1)
        printf("Case %d is a tree.\n",count);
        else
        printf("Case %d is not a tree.\n",count); 
        count++;
    }
    return 0;
}
            
    

多亏了水题……我可以去睡觉了……


今天由于hdu上不了去逛poj了,遇到了一道一样的题,邪恶的用此代码直接交……居然wa!!!在discuss里翻了翻发现原来空树也算树……好吧,其实好像有道题有这样的猥琐的数据,当时没在意……唉……

加了一个新的flag就好了~

#include <iostream>
#define m 100001
using namespace std;
int a,b,flag;
int set[m];
int v[m];
int i;
int main()
{
    int count=1;
    int flag2;
    while(cin>>a>>b)
    {
        if(a<0&&b<0)
        {break;}
        flag=0;
        flag2=0;
        for(i=1;i<m;i++)
        {
            set[i]=0;
            v[i]=0;
        }
        int e=0;
        while(a&&b)
        {
            flag2=1;
            if(!v[a])
            {
                v[a]=1;
                e++;
            }
            if(!v[b])
            {
                v[b]=1;
                e++;
            }
            e--;
            if(set[b]==0)//b is root
            {
                set[b]=1;
            }
            else
            {
                flag=1;
                break;
            }
            cin>>a>>b;
        }
        while(a && b) { scanf("%d %d",&a,&b);} 
        if((!flag&&e==1)||flag2==0)
        printf("Case %d is a tree.\n",count);
        else
        printf("Case %d is not a tree.\n",count); 
        count++;
    }
    return 0;
}
            
    



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值