POJ 1985 Cow Marathon(牛的锻炼,树的直径)

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 5000 Accepted: 2429
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

Source



题意:

POJ 2631(点击查看) 差不多。这题目的大意就是,多让牛锻炼,保护好身体,不生病。

也就是给一些边,问哪两个节点的距离最大。


思路:
树的最大直径,相当于模板题,做了2631,这个就挺简单的了!


代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int MYDD=110300;

int edgenum;//边的数目
int head[MYDD];//节点头指针
void init_edge() {
	edgenum=0;
	memset(head,-1,sizeof(head));
}

struct EDGE { //边的信息
	int u,v,w,next;
} edge[MYDD*2];
void addedge(int u,int v,int w) {//增加边信息
	EDGE Edge= {u,v,w,head[u]};//可以学习这种方法赋值
	edge[edgenum]=Edge;
	head[u]=edgenum++;
}

bool vis[MYDD];//记录节点的访问状态
int dis[MYDD];//记录节点所在直径的最大值
int Tnode,ans;
void BFS(int sx) {
	queue<int> Q;
	memset(vis,false,sizeof(vis));
	memset(dis,0,sizeof(dis));
	vis[sx]=true;
	Q.push(sx);
	Tnode=sx;
	ans=0;
	while(!Q.empty()) {
		int first=Q.front();
		Q.pop();
		for(int j=head[first]; j!=-1; j=edge[j].next) {
			int v=edge[j].v;
			if(!vis[v]) {
				if(dis[v]<edge[j].w+dis[first]) {
					dis[v]=edge[j].w+dis[first];
				}
				vis[v]=true;
				Q.push(v);
				if(ans<dis[v]) {
					ans=dis[v];
					Tnode=v;
				}
			}
		}
	}
}

int main() {
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF) {
		init_edge();
		while(m--) {
			int u,v,w;
			char dd[4];
			scanf("%d%d%d%s",&u,&v,&w,dd);
			addedge(u,v,w);
			addedge(v,u,w);//再写成 u,v,w 试试 
		}
		BFS(1);
		BFS(Tnode);
		printf("%d\n",ans);
	}
}



后:

**************


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值