关闭

Window7—64位:Ruby on Rails - “Add 'gem sqlite3'' to your Gemfile”

标签: ruby on rails
1142人阅读 评论(0) 收藏 举报
分类:

解决问题的方法http://stackoverflow.com/questions/17350837/ruby-on-rails-add-gem-sqlite3-to-your-gemfile/17409859

—————————————————下面我来解释一下—————————————————

有人原来告诉我在WIN7下装ROR,出了什么错都是情有可原的,明明我装了sqlite3,而且在Gemfile文件夹中还有Add 'gem sqlite3',为什它老提示我要 “Add 'gem sqlite3'' to your Gemfile”呢,下面是解决方法!!

——————————————————————————————————————————

打开Gemfile.lock文件,注意,不是Gemfile.lock,在sqlite3(1.3.8-x86-mingw32)中,只要把-x86-mingw32去掉就可以了,至于为什么我现在也不知到,估计就是WIN环境不适合吧。

改过了之后就bundle install

这个时候你就可以在里面找到   Using sqlite3 (1.3.8)  这样的字段,恭喜你,好了

然后你再重新启动,你就可以看到。。。。。。。。


——————————————————————————————————————————

再最后还是再奉劝大家一句,用LINUX或MAC吧,不要用WIN7。。。。。

0
0
查看评论
发表评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场

Ruby Thin服务器——比Rails自带的Webrick快不止一个档次!

最快速的上手方法:(亲测可用,效果明显) 1.安装gem_在控制台输入 gem install thin 2.运行服务器 在网站对应的目录下 输入 start thin 替换原来的 Rails...
  • winbobob
  • winbobob
  • 2015-01-08 03:18
  • 2445

Gemfile指定gem来源的四种方式

Gemfile的作用无非就是告诉bundler你的项目具体都需要哪些gem,这些gem都需要哪些版本,以及从哪获取这些gem。其实你的问题应该就是跟第三点有关,总的来说,gem的来源可以有四种: ...
  • xiangyong882000
  • xiangyong882000
  • 2015-01-05 02:48
  • 1583

ruby thin跑不起来的各种原因大总结

##首先是基本的thin安装与配置,这个没什么好说的,大家都不会出什么意外 1. gem install thin gem install therubyracer gem install bs...
  • lile1234_show
  • lile1234_show
  • 2014-03-14 11:16
  • 2002

jPush极光推送tips,(ruby<2.2)

最近,极光推出了新版本的服务器端sdk,但是仅针对ruby版本2.2以上,那么对于老项目如何才能使用极光推送服务呢? 前言: 对于ROR项目来说,应该使用  jpush-api-ruby-clie...
  • h6941902
  • h6941902
  • 2016-07-15 09:17
  • 315

gem rails安装、卸载、和使用 指定版本

原文地址:http://fsjoy.blog.51cto.com/318484/100660 安装指定版本: gem install rails -v 版本号   卸载指定版本: ge...
  • w13770269691
  • w13770269691
  • 2014-03-18 10:43
  • 11902

Rails Gem开发(二)——whenever实现周期性任务

根据项目的进展,我们需要实现后台进行定时读取信息的功能,而最关键的实现部分是周期性功能,根据调研,决定使用whenever来实现这一功能。 github:https://github.com/jav...
  • vito0705
  • vito0705
  • 2016-10-26 10:35
  • 810

【证明可用】Ubuntu14.04/16.04命令行快速安装Ruby和Rails运行环境

Rails运行环境的安装一直都是比较困难的,即使是熟练的Rails开发人员,都可能在安装过程中出现各种问题。注意:看到 ## 符号可以不用理会。是我安装过程一些步骤过程遇到的问题并加入了一些说明...
  • qq_24805141
  • qq_24805141
  • 2016-04-22 22:00
  • 2607

ruby gem 本地安装方法

问题: railsinstaller中没有默认带有mysql的gem。 使用railsinstaller安装配置完rails环境后,发现无法使用gem update --system等更新或者安装...
  • sdulibh
  • sdulibh
  • 2015-12-12 16:26
  • 3441

Rails 图表解决方案汇总

最近需要给 抢座 增加图表功能,于是对Rails的图表方案做了些调查,整理成这篇贴,希望对有同样需求的人有所帮助。 Google Chart Google Chart的优点是接口简单,容易...
  • dazhi_100
  • dazhi_100
  • 2014-05-08 20:47
  • 1130

用 Ruby on Rails 实现适应各种平台的在线 Office 文档预览

http://ruby-china.org/topics/17309 前言 在许多Web应用中都需要预览文档的功能。而用户可能用不同的设备访问Web应用,可能是装有Windows系统的PC台式...
  • tongxiaomingicesword
  • tongxiaomingicesword
  • 2016-11-24 19:18
  • 297
    个人资料
    • 访问:124803次
    • 积分:2191
    • 等级:
    • 排名:第19896名
    • 原创:90篇
    • 转载:0篇
    • 译文:4篇
    • 评论:133条
    联系方式
    QQ联系方式
    作者日本硕士
    知识长期输入中
    技术长期磨练中
    如有问题或交流
    请QQ联系 649508982
    来者请说明CSDN
    或者加入机器学习交流群
    不定期发送pdf等学习资源
    QQ群号:657119450
    机器学习 QQ群加入
    博客专栏