Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib (LoadError)出错

原创 2014年06月18日 19:19:19
/Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:106:in `require': dlopen(/Users/silei/.rvm/rubies/ruby
-2.0.0-p247/lib/ruby/2.0.0/x86_64-darwin13.2.0/digest/md5.bundle, 9): Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib (LoadError
)
  Referenced from: /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/x86_64-darwin13.2.0/digest/md5.bundle
  Reason: image not found - /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/x86_64-darwin13.2.0/digest/md5.bundle
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:106:in `require'
        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/gems/railties-4.0.1/lib/rails/generators/app_base.rb:1:in `<top (required)>'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/gems/railties-4.0.1/lib/rails/generators/rails/app/app_generator.rb:1:in `<top (required)>'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/gems/railties-4.0.1/lib/rails/commands/application.rb:29:in `<top (required)>'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/gems/railties-4.0.1/lib/rails/cli.rb:15:in `<top (required)>'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/gems/railties-4.0.1/bin/rails:9:in `<top (required)>'
        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/bin/rails:23:in `load'

        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/bin/rails:23:in `<main>'



原因:libssl找不到,其实是ruby升2.0.0的时候出错,gem需要重装。


解决方法:

重装ruby!!!!


rm -rf /usr/local/Cellar /usr/local/.git && brew cleanup

ruby -e "$(curl -fsSL https://raw.github.com/mxcl/homebrew/go/install)"

rvm reinstall 2.0.0          (主要步骤)

rvm 2.0.0 --default

gem source -r https://rubygems.org/

gem source -a https://ruby.taobao.org


版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

解决 “dyld: Library not loaded: ” 错误

今天在Mac上搞了一个动态库(开发环境Eclipse+sconsolidator), 生成dylib倒是简单。随后新建一个可执行的demo, 链接时在设置里指定dylib的目录和相应的库名,但-L参数...
  • ani_di
  • ani_di
  • 2011年12月16日 21:27
  • 31125

服务器软件常见问题

sudo brew install nginx 1. 安装nginx 之后遇到 dyld: Library not loaded: @@HOMEBREW_CELLAR@@/openssl/...
  • kllxyu
  • kllxyu
  • 2014年10月10日 09:03
  • 852

Mac下配置OpenSSL

Mac本身已经有OpenSSL可以直接用,提供的相关的依赖库如下: XCLiMac:openssl-0.9.8zg xcl$ ls -l /usr/lib/libssl.dylib lrwxr-xr...

mac : dyld: Library not loaded 问题解决

在mac中用xcode编写了一个命令行程序,其中引入了一个framework,最终生成一个可执行程序。 在自己电脑上测试一切正常,可到其他mac中使用此程序,报如下错误: dyld: Libr...
  • skyztttt
  • skyztttt
  • 2012年10月26日 14:37
  • 18633

linux /centos 中OpenSSL升级方法详解

OpenSSL升级前段时间出现天大bug了,这样导致大家都急着去升级OpenSSL来初安全了,但是很多的朋友在家linux并不知道如何去升级OpenSSL了,下面我整理了一文章大家一起参考一下。 ...
  • xysoul
  • xysoul
  • 2015年11月18日 22:01
  • 17778

openssl-1.1.0c在linux 64位下的升级方法

1、查看源版本 openssl version -a OpenSSL 1.0.1e-fips 11 Feb 2013 2、下载openssl-1.1.0c.tar.gz https://w...

解决mac osx编译libevent找不到openssl目录的问题

用如下方式去configure(指定openssl的实际路径) ./configure --prefix=/usr/local CPPFLAGS="-I/usr/local/Cell...

QT 无法链接动态库 dyld library not loaded ... libhdf5.100.dylib

qt dyld library not loaded …/libhdf5.100.dylib分析无法链接动态库,考虑手动添加链接。...
  • huihut
  • huihut
  • 2017年06月13日 23:08
  • 452

Native Library /usr/lib/libJMagick.so already loaded in another classloader

最近安装了ImageMagick的应用服务器报如下异常: java.lang.UnsatisfiedLinkError: Native Library /usr/lib/libJMagick.s...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib (LoadError)出错
举报原因:
原因补充:

(最多只允许输入30个字)