Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib (LoadError)出错

标签: ruby on rails ruby rvm gem rails
3760人阅读 评论(0) 收藏 举报
分类:
/Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:106:in `require': dlopen(/Users/silei/.rvm/rubies/ruby
-2.0.0-p247/lib/ruby/2.0.0/x86_64-darwin13.2.0/digest/md5.bundle, 9): Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib (LoadError
)
  Referenced from: /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/x86_64-darwin13.2.0/digest/md5.bundle
  Reason: image not found - /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/x86_64-darwin13.2.0/digest/md5.bundle
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:106:in `require'
        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/gems/railties-4.0.1/lib/rails/generators/app_base.rb:1:in `<top (required)>'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/gems/railties-4.0.1/lib/rails/generators/rails/app/app_generator.rb:1:in `<top (required)>'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/gems/railties-4.0.1/lib/rails/commands/application.rb:29:in `<top (required)>'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/gems/railties-4.0.1/lib/rails/cli.rb:15:in `<top (required)>'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:58:in `require'
        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/gems/railties-4.0.1/bin/rails:9:in `<top (required)>'
        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/bin/rails:23:in `load'

        from /Users/silei/.rvm/gems/ruby-2.0.0-p247/bin/rails:23:in `<main>'



原因:libssl找不到,其实是ruby升2.0.0的时候出错,gem需要重装。


解决方法:

重装ruby!!!!


rm -rf /usr/local/Cellar /usr/local/.git && brew cleanup

ruby -e "$(curl -fsSL https://raw.github.com/mxcl/homebrew/go/install)"

rvm reinstall 2.0.0          (主要步骤)

rvm 2.0.0 --default

gem source -r https://rubygems.org/

gem source -a https://ruby.taobao.org


查看评论

mac : dyld: Library not loaded 问题解决

在mac中用xcode编写了一个命令行程序,其中引入了一个framework,最终生成一个可执行程序。 在自己电脑上测试一切正常,可到其他mac中使用此程序,报如下错误: dyld: Libr...
  • skyztttt
  • skyztttt
  • 2012-10-26 14:37:59
  • 20591

服务器软件常见问题

sudo brew install nginx 1. 安装nginx 之后遇到 dyld: Library not loaded: @@HOMEBREW_CELLAR@@/openssl/...
  • kllxyu
  • kllxyu
  • 2014-10-10 09:03:35
  • 1066

dyld: Library not loaded: /usr/local/opt/readline/lib/libreadline.6.dylib

欢迎访问我的个人博客网站:http://www.yanmin99.com/ 问题描述dyld: Library not loaded: /usr/local/opt/readline/lib/libr...
  • lcyaiym
  • lcyaiym
  • 2017-08-16 23:55:19
  • 1053

解决 “dyld: Library not loaded: ” 错误

今天在Mac上搞了一个动态库(开发环境Eclipse+sconsolidator), 生成dylib倒是简单。随后新建一个可执行的demo, 链接时在设置里指定dylib的目录和相应的库名,但-L参数...
  • ani_di
  • ani_di
  • 2011-12-16 21:27:11
  • 36413

XCode6添加自定义framework运行真机出现dyld: Library not loaded的解决方法

笔记下,bei
  • cooldragon
  • cooldragon
  • 2014-09-30 17:25:16
  • 28310

cocoapods:常见错误总结

cocoapods 第三方库管理工具问题总结
  • wangyanchang21
  • wangyanchang21
  • 2016-05-17 17:36:33
  • 41546

apache 在 加载openssl 模块时出现 “/usr/local/ssl/lib/libssl.a: could not read symbols: Bad value”错误解决方案

正式环境: 系统:Red Hat Enterprise Linux Server release 5.6 (Tikanga) 内核:2.6.18-238.31.1.el5 位数:64 测试环境...
  • nyist327
  • nyist327
  • 2015-02-06 16:25:34
  • 7958

解决libssl.so.1.0.0: 找不到的问题

安装了多个版本的openssl后,导致adb或svn无法使用,出现以下错误:libssl.so.1.0.0: no version information available记录下最后的解决方法,百度...
  • yuhonqin
  • yuhonqin
  • 2016-03-24 16:42:37
  • 5596

nginx安装的一些问题

安装nginx本觉得很容易的事,结果把我整惨了,一开始按照提示的错误,q去下载了各种依赖包,包括zlib-1.2.4 ,openssl-0.9.8,pcre等,并手动编译,安装。。。 进入Nin...
  • zhilong002
  • zhilong002
  • 2016-06-14 17:53:33
  • 7202

nginx 编译错误解决方法 [备忘]

参见编译错误信息can not detect int size 增加参数可以跳过--with-ld-opt="-lstdc++" --with-cpp_test_module   参考编译错...
  • signmem
  • signmem
  • 2014-02-08 00:29:01
  • 30440
    个人资料
    专栏达人
    等级:
    访问量: 15万+
    积分: 2500
    排名: 1万+
    机器学习 QQ群加入
    博客专栏
    最新评论