SDAU 搜索专题 13 A strange lift

1:问题描述
Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can’t go up high than N,and can’t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you’ll go up to the 4 th floor,and if you press the button "DOWN", the lift can’t do it, because it can’t go down to the -2 th floor,as you know ,the -2 th floor isn’t exist.
Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button "UP" or "DOWN"?

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,….kn.
A single 0 indicate the end of the input.

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.

Sample Input
5 1 5
3 3 1 2 5
0

Sample Output
3

2:大致题意

一个电梯,只有上,下,两个按钮。而且上和下的层数是给定的,
给你起始位置和,结束位置。要判断是否可以到达。

3:思路

在某个楼层,分别将它上升和下降达到的楼层记录下来,放入队列里面。如果达到指定楼层就记录下来并结束。
要记得清空队列。

4:感想

这个题,我写的代码好像有不对的地方不过倒是ac了。。

5:ac代码

#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
struct node
{
   int x ;
   int t ;
}n1,n2,m;
int c[2000],ww[2000];  //标记数组,和一个记录楼层状态的数组
int flag ;                 //记录能否到达目标楼层
int n , a , b ;          //n层,a,起始楼层,b,目的楼层
int main(  )
{
    while( scanf("%d" , &n ) , n )
    {
       if( n== 0 ) break ;        //结束
       cin>>a>>b;
       for( int i= 1;  i<= n ; i++ )     //初始化
       { cin>>ww[i] ; c[i] = 0 ; }
       flag = 0 ;                      //初始为0
       n1.x = a ; n1.t = 0 ;        //把a开始所在楼层赋给结构体, 所走步数为0
       queue<node>Q;               //建立队列Q
       Q.push(n1);                        //入队
       c[n1.x] = 1 ;          //标记已经走过
       while( !Q.empty() )       //直到为空为止
       {
          m = Q.front() ;            //把队列中第一个值赋给结构体变量m
          Q.pop();                   //出队
          if( m.x == b )            //如果到达终点便退出
          { flag = 1 ; break ; }
          n1.x = m.x - ww[m.x];  //按向下的按钮
          n2.x = m.x + ww[m.x]; //按向上的按钮
          if( n1.x>0 && n1.x<= b && !c[n1.x] )//向下
          {
                n1.t = m.t + 1 ;         //步数加一
                c[n1.x] = 1 ;       //标记
                Q.push(n1);
              }
            if( n2.x>0 && n2.x<= b && !c[n2.x] )//向上
             {
                n2.t = m.t+1 ;
                c[n2.x] = 1 ;
                Q.push(n2);
             }
       }
       if( flag ) cout<<m.t<<endl;
       else cout<<"-1"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值