Curling 2.0 (深搜)

Curling 2.0

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 38   Accepted Submission(s) : 9
Problem Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

 

Input
<p>The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.</p><p>Each dataset is formatted as follows.</p><blockquote><p><i>the width(=w) and the height(=h) of the board</i> <br><i>First row of the board</i> <br>... <br><i>h-th row of the board</i></p></blockquote><p>The width and the height of the board satisfy: 2 <= <i>w</i> <= 20, 1 <= <i>h</i> <= 20.</p><p>Each line consists of <i>w</i> decimal numbers delimited by a space. The number describes the status of the corresponding square.</p><blockquote><table id="table1"><tr><td>0 </td><td>vacant square</td></tr><tr><td>1 </td><td>block</td></tr><tr><td>2 </td><td>start position</td></tr><tr><td>3 </td><td>goal position</td></tr></table></blockquote><p>The dataset for Fig. D-1 is as follows:</p><blockquote><p>6 6 <br>1 0 0 2 1 0 <br>1 1 0 0 0 0 <br>0 0 0 0 0 3 <br>0 0 0 0 0 0 <br>1 0 0 0 0 1 <br>0 1 1 1 1 1</p></blockquote>
 

Output
<p>For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.</p>
 

Sample Input
  
  
2 1 3 2 6 6 1 0 0 2 1 0 1 1 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 1 0 0 0 0 1 0 1 1 1 1 1 6 1 1 1 2 1 1 3 6 1 1 0 2 1 1 3 12 1 2 0 1 1 1 1 1 1 1 1 1 3 13 1 2 0 1 1 1 1 1 1 1 1 1 1 3 0 0
 

Sample Output
  
  
1 4 -1 4 10 -1
 

Source
PKU

题意:

有一个宽为w长为h的正方形网格,有些小方格内有石头,阻碍通过,给定你起始位置,让你找到最少移动步数。

思路:

此题和以往的类似的题目不同,这是直线搜索,以直线的形式来搜索,首先空白的方格直接继续沿当前方向走,直到碰见石头或出界才结束!当找到3时直接return。注意一些细节:

当现在点的相邻点有石头时,就不能在往该方向,还有就是当碰到石头上,石头消失,而冰壶是停在到达石头的上一个位置的。这两个点很关键,一开始忽略了,wa了好几次。。。

代码:


#include <iostream>
#include <stdio.h>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
using namespace std;
int mp[200][200];
int ans,sx,sy;
int w,h;
int dx[4]={-1,0,1,0};//四个方向
int dy[4]={0,1,0,-1};
void dfs(int x,int y,int num)//x y代表当前坐标,num代表步数
{
    int i;
    if(num>10)return;//num是从0开始所以要小与10
    for(i=0;i<4;i++)//四个方向
    {
        if(mp[x+dx[i]][y+dy[i]]==1)continue;//相邻得点有石头,直接跳过这个方向
        int xx,yy;
        int flag=0;
        xx=x,yy=y;
        while(1)   //此处很巧妙,也是关键之点,它是直线搜索的保证
        {
            xx=xx+dx[i];yy=yy+dy[i];
            if(xx<=0||xx>w||yy<=0||yy>h){flag=1;break;}//越界了,做标记
            if(mp[xx][yy]==0)continue;   //等于0,沿着这方向一直前进
            if(mp[xx][yy]==1)break;//等于1了,则这个方向也就停止了
            if(mp[xx][yy]==3){ans=min(ans,num);return;}//找到目标,直接结束
        }
        if(flag)continue; //如果越界,则这个方向就跳过
        mp[xx][yy]=0;  //未越界时,把石头消失
        dfs(xx-dx[i],yy-dy[i],num+1); //注意,冰壶是停留在上一位置的。。WA了好多
        mp[xx][yy]=1;
    }
}
int main()
{

    //freopen("a.txt","r",stdin);
    ios::sync_with_stdio(false);
    int i,j;
    while(cin>>w>>h,w+h)
    {
        memset(mp,0,sizeof(mp));
        ans=11;
        for(i=1;i<=w;i++)
            for(j=1;j<=h;j++)
        {
            cin>>mp[i][j];
            if(mp[i][j]==2){sx=i,sy=j;mp[i][j]=0;}
        }
        dfs(sx,sy,0);
        if(ans<10)
            cout<<ans+1<<endl;
        else
            cout<<"-1"<<endl;

    }
    return 0;
}
心得:

题目比较新颖,但仔细分析,其实并不是很难!

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值