A Knight's Journey (深度搜索+字典序)

A Knight's Journey

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 125   Accepted Submission(s) : 26
Problem Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
 

Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
 

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.<br>If no such path exist, you should output impossible on a single line.
 

Sample Input
  
  
3 1 1 2 3 4 3
 

Sample Output
  
  
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
 

Source
PKU
 

思路:

棋盘的遍历问题首先想到的是广搜,但深搜其实也适合!此题运用了一些技巧。首先单独创建一个输出函数,用来进行数据的输出,还有就是字符的处理上,将列仍然看成数字,然后在搜索函数里在转换成字符,以便存储位置。搜索的形式是(int x,int y,int step),其中xy表示几行几列(据y由y+'A'-1算出字符列),起点是(1,1,1).从头开始搜索,结束是如果x*y==step时,则搜索到结果,此时可以输出,在这个判断输出的问题上(即是否可以搜索到!)可以用一个flag标志,还有就是字典序的控制,一定要严格按照顺序进行搜索,还有就是要注意输出的格式,每组测试数据中间要有空格!

代码:

#include <stdio.h>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int dir[8][2]={-1,-2,1,-2,-2,-1,2,-1,-2,1,2,1,-1,2,1,2};   //严格按照顺序
bool vis[30][30];    //判断是否走过
int cas,r,c,flag=0,t;
struct point
{
    int s;
    char s1;
}p[666];
void print()   //输出函数
{
    cout<<"Scenario #"<<cas<<":"<<endl;
    for(int i=1;i<=r*c;i++)
    cout<<p[i].s1<<p[i].s;
    cout<<endl;
    if(t!=0)
        cout<<endl;

}
bool judge(int x,int y)//判断是否越界以及是否走过
{
    if(vis[x][y]==0&&x>0&&x<=r&&y>0&&y<=c&&flag==0)
    return true;
    else
    return false;
}
void dfs(int x,int y,int step)
{
    p[step].s=x;
    p[step].s1='A'+y-1; //换成字符
    if(step==r*c)  //结束
    {
        flag=1;
        return;
    }
    for(int i=0;i<8;i++)
    {
        int xx=x+dir[i][0];
        int yy=y+dir[i][1];
        if(judge(xx,yy))
        {
            vis[xx][yy]=1;
            dfs(xx,yy,step+1);
            vis[xx][yy]=0;
        }
    }
}
int main()
{
    cas=0;
    cin>>t;
    while(t--)
    {
      cas++;
      cin>>r>>c;
      p[1].s1='A';
      p[1].s=1;
      flag=0;
      memset(vis,0,sizeof(vis));
      vis[1][1]=1;
      dfs(1,1,1);
      if(flag)
        print();
      else
      {
          cout<<"Scenario #"<<cas<<":"<<endl;
          cout<<"impossible"<<endl;
          if(t!=0)
            cout<<endl;
      }
    }
    return 0;

}

心得:

不是很难得题目,但需要细心仔细,多总结!

  • 3
    点赞
  • 14
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值