Chinese Zodiac(水题)

Chinese Zodiac

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig.
Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them.
If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be 2 years. But if the signs of the couple is the same, the answer should be 12 years.
 

Input
The first line of input contains an integer T (1T1000) indicating the number of test cases.
For each test case a line of two strings describes the signs of Victoria and her husband.
 

Output
For each test case output an integer in a line.
 

Sample Input
  
  
3 ox rooster rooster ox dragon dragon
 

Sample Output
  
  
8 4 12
 

Source
  
  
输入输出测试
 

题意:

给你12个生肖,给你两个人的生肖,判断两个人最小的年龄差!

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
#define M 105
string s1,s2;
int main()
{
    int T;
    map<string,int> p;
    p["rat"]=1;
    p["ox"]=2;
    p["tiger"]=3;
    p["rabbit"]=4;
    p["dragon"]=5;
    p["snake"]=6;
    p["horse"]=7;
    p["sheep"]=8;
    p["monkey"]=9;
    p["rooster"]=10;
    p["dog"]=11;
    p["pig"]=12;
    scanf("%d",&T);
    while(T--)
    {
        cin>>s1>>s2;
        //printf("%d %d\n",p[s1],p[s2]);
        if(s1==s2) printf("%d\n",12);
        else
        {
            if(p[s1]<p[s2]) printf("%d\n",p[s2]-p[s1]);
            else printf("%d\n",((12-p[s1])+p[s2]));
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值