1059. Prime Factors

1059. Prime Factors (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HE, Qinming

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1* p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291
从最小的素数2开始往上找即可,注意输入为1时输出1=1。
#include <iostream>
#include <algorithm>

using namespace std;

long long prime(long long s, long long n)
{
	long long r=n;
	for(int i=s;i<=sqrt(double(n));++i)
		if(n%i==0)
			return i;
	return r;
}

int main()
{
	long long n;
	cin>>n;
	long long tmp=2,cnt;
	bool f=false;
	cout<<n<<"=";
	if(n==1)
		cout<<n<<endl;
	while(tmp<=n)
	{
		cnt=0;
		tmp=prime(tmp,n);
		while(n%tmp==0)
		{
			cnt++;
			n/=tmp;
		}
		if(f)
			cout<<"*";
		else
			f=true;
		cout<<tmp;
		if(cnt>1)
			cout<<"^"<<cnt;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值