东大OJ-1430-PrimeNumbers

题目描述

I'll give you a number , please tell me how many different prime factors in this number.

输入

There is multiple test cases , in each test case there is only one line contains a number N(2<=N<=100000). Process to the end of file.

输出

For each test case , output one line contains one number , indicating different prime factor in the number N.

样例输入

12
5
30

样例输出

2
1
3

提示

12 = 2 * 2 * 3

5 = 5

30 = 2 * 3 * 5 


#include<iostream>
using namespace std;
int a[100001];
void go(){
	memset(a, 0, sizeof(a));
	int i,j;
	for (i = 2; i < 100001;i++)
	if (a[i] == 0){
		for (j = i; j < 100001; j+=i)a[j]++;
	}
}
int main(){
	//freopen("in.txt", "r", stdin);
	int x;
	go();
	while (cin >> x)cout << a[x] << endl;
	return 0;
}


转载于:https://www.cnblogs.com/weiyinfu/p/5013910.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值