PAT 1099. Build A Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

    Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

    Sample Input:
    9
    1 6
    2 3
    -1 -1
    -1 4
    5 -1
    -1 -1
    7 -1
    -1 8
    -1 -1
    73 45 11 58 82 25 67 38 42
    
    Sample Output:
    58 25 82 11 38 67 45 73 42
    

思路:按给定格式构造二叉树,判断每个节点左侧有几个节点,按顺序给节点赋值,最后广度搜索按树的层次输出


#include <stdio.h>
#include <algorithm>
#include <queue>
using namespace std;
struct Node
{
	int val, lc, rc;
	int cntL, cntR;
};
int N, input[110];
Node list[110];

int fun(int root)
{
	if(root == -1)
	{
		return 0;
	}
	list[root].cntL = fun(list[root].lc);
	list[root].cntR = fun(list[root].rc);
	return list[root].cntL + list[root].cntR + 1;
}

void setVal(int root, int ls, int rs)
{
	if(root == -1)
	{
		return;
	}
	int temp = list[root].cntL + ls;
	list[root].val = input[temp];
	setVal(list[root].lc, ls, list[root].cntL);
	setVal(list[root].rc, temp + 1, rs);
}

int main()
{
	while(scanf("%d", &N) != EOF)
	{
		for(int i = 0; i < N; i++)
		{
			scanf("%d %d", &list[i].lc, &list[i].rc);
			list[i].cntL = 0;
			list[i].cntR = 0;
		}
		for(int i = 0; i < N; i++)
		{
			scanf("%d", &input[i]);
		}
		sort(input, input + N);
		fun(0);
		setVal(0, 0 ,N - 1);
		queue<Node> dp;
		dp.push(list[0]);
		int level = 0;
		while(dp.size())
		{
			int length = dp.size();
			level++;
			for(int i = 0; i < length; i++)
			{
				if(dp.front().lc != -1)
				{
					dp.push(list[dp.front().lc]);
				}
				if(dp.front().rc != -1)
				{
					dp.push(list[dp.front().rc]);
				}
				if(level == 1)
				{
					printf("%d", dp.front().val);
				}
				else
				{
					printf(" %d", dp.front().val);
				}
				dp.pop();
			}
		}
		printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值