HDU 1059 - Dividing(多重背包)

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output

For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.
 

Sample Input

    
    
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output

  
  
Collection #1: Can't be divided. Collection #2: Can be divided.

                                                      

多重背包的基础题。这一种做法是将其转化成完全背包,使用一个数组记录其数量。

在双重循环里面的if 的判断应该加一个 !dp[j] , 因为倘若前面的物品已经能够到达dp[j]这个状态时,再使用后面的物品到达这个状态势必会造成浪费,题目的要求能否达到这个状态,则要加上这个判断。这种写法的判断比较复杂, 不提倡。

CODE:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int inf = 0xfffffff;

int m[10], p[10], u[120005];
bool dp[120100];

int main()
{
    //freopen("in", "r", stdin);
    int a;
    int ca = 0;
    while(1){
        ca++;
        int n = 0, s = 0;
        for(int i = 1; i <= 6; ++i){
            scanf("%d", &a);
            s += i*a;
            if(a != 0){
                p[n] = a; //数量
                m[n] = i; //价值
                n++;
            }
        }
        if(s == 0) break;
        if(s%2 == 1){
            printf("Collection #%d:\nCan't be divided.\n\n",ca);
            continue;
        }
        s /= 2;
        for(int i = 0; i <= s; ++i) dp[i] = false;
        dp[0] = true;
        for(int i = 0; i < n; i ++){
            memset(u, 0, sizeof(u));
            for(int j = m[i]; j<= s; ++j){
                if(!dp[j] && dp[j - m[i]] && u[j - m[i]] < p[i]){
                    dp[j] = true;
                    u[j] = u[j - m[i]] + 1;
                }
            }
        }
        if(dp[s] != false) {
            printf("Collection #%d:\nCan be divided.\n\n", ca);
        }
        else printf("Collection #%d:\nCan't be divided.\n\n", ca);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值