Agri-Net

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

题意: 要求得到n个农场间最小的距离.

思路: 并查集

          运用结构体储存数据..新技能: 对结构体进行排序

          注意: 应该是根节点和根节点的连接

code:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
struct farm
{
   int u;
   int v;
   int d;
}f[10005];
int set[10005];
int fa[10005][10005];

int find(int x)
{
    if(x==set[x])return x;
    else return set[x]=find(set[x]);
}

bool cmp(farm a,farm b)
{
    return a.d<b.d;
}

int main()
{
    //freopen("G.txt","r",stdin);
    int n;
    while(~scanf("%d",&n))
    {
       // memset(f,0,sizeof(f));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&fa[i][j]);
            }
            //getchar();
        }
        int k=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                f[k].u=i;
                f[k].v=j;
                f[k].d=fa[i][j];
                k++;
            }
        }
        sort(f,f+k,cmp);

        for(int i=1;i<=n;i++)
           set[i]=i;
        int num=0,s=0;
        for(int i=0;i<k;i++)
        {
            if(num==n-1)break;
            if(find(set[f[i].u])!=find(set[f[i].v]))
            {
                set[find(set[f[i].v])]=find(set[f[i].u]);//一个数的根节点接到另一个数的根节点~
                s+=f[i].d;
                num++;
            }
        }
         printf("%d\n",s);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值