nyoj284 坦克大战(dijkstra(bfs+优先队列))

坦克大战

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 

Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?
输入
The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
输出
For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.
样例输入
3 4
YBEB
EERE
SSTE
0 0
样例输出
8
来源
POJ
上传者
sadsad
做这道题吧我累死了。。。哎。写个博客歇歇0.0
让我看这道题,我认为就是最短路径问题。当然,关键看你能不能往那里去想,想到了其实也是很简单的。也就是dijkstra,看评论区别人都是用dfs+优先队列,不还是dijkstra思想嘛。。
如果还不懂dijkstra思想的同学建议找度娘。。。
其实这道题我错了整整一页,因为我认为我一直是对了。改改格式什么的。还是不行,最后瞟了一眼map[304][30]....果然手残漏打了一个4...
改了就AC了。希望那些如果认为自己代码正确的童鞋多看看细节。而且是那种最不容易想到的简单的地方。
奉上代码
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
struct node
{
	int x,y,step;
	friend	bool operator <(node a,node b)
	{
		return a.step>b.step;
	}
};
priority_queue<node> s;//结构体优先队列
char map[304][304];
int m,n,visit[304][304],dir[4][2]={1,0,-1,0,0,1,0,-1};//vis标记是否访问,dir代表四个方向
bool limit(int x,int y)//判断是否出界和此刻指向的位置是否是水和石头
{
	if(x>=0&&y>=0&&x<m&&y<n&&map[x][y]!='S'&&map[x][y]!='R')
	return true;
	else
	return false;
}
int tonum(char c)//把对应的字母转换为需要的步数
{
	if(c=='B')
	return 2;
	if(c=='E'||c=='T')
	return 1;
}
int bfs(int star,int end)
{
	node temp,sta;
	visit[star][end]=1;//Y位置标记为1
	temp.x=star,temp.y=end,temp.step=0;
	s.push(temp);
	while(!s.empty())//完全是dijkstra思想 看不懂的百度吧
	{
		int ant;
		temp=s.top();
		s.pop();
		star=temp.x,end=temp.y,ant=temp.step;
		for(int i=0;i<4;i++)
		{
			temp.x+=dir[i][0];
			temp.y+=dir[i][1];
			if(limit(temp.x,temp.y)&&!visit[temp.x][temp.y])
			{
				visit[temp.x][temp.y]=1;
				temp.step+=tonum(map[temp.x][temp.y]);
				if(map[temp.x][temp.y]=='T')
				return temp.step;
				s.push(temp);
			}
			temp.x=star,temp.y=end,temp.step=ant;
		}
	}
	return -1;
}
int main()
{
	int star_x,star_y;
	while(scanf("%d %d",&m,&n)!=EOF&&(m||n))
	{
		for(int i=0;i<m;i++)
		scanf("%s",map[i]);
		for(int i=0;i<m;i++)
		for(int j=0;j<n;j++)
		{
			if(map[i][j]=='Y')
			star_x=i,star_y=j;
		}
		memset(visit,0,sizeof(visit));
		printf("%d\n",bfs(star_x,star_y));
		while(!s.empty())
		s.pop();
		memset(map,0,sizeof(map));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值