poj 2312( 搜索 )

Battle City
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5789 Accepted: 1913

Description

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 

What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 

Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

Sample Input

3 4
YBEB
EERE
SSTE
0 0

Sample Output

8

Source

POJ Monthly,鲁小石



题目类型:搜索

题目描述:略

题目分析:略


代码如下:

#include <iostream>
#include <stdio.h>
#include <queue>
#define N 301
using namespace std;

char map[N][N];
bool visit[N][N];
int dx[4] = {-1,0,1,0};
int dy[4] = {0,1,0,-1};
int row,column;
struct Point{
    int x;
    int y;
    int step;
} c,r;
priority_queue<Point> Q;

bool operator < (const Point &a,const Point &b){
    return a.step > b.step;
}

int bfs(int x,int y){
    memset(visit,false,sizeof(visit));
    while(!Q.empty()){
        Q.pop();
    }
    visit[x][y] = true;
    r.x = x; r.y = y; r.step = 0;
    Q.push(r);
    while( !Q.empty()){
        c = Q.top();
        for(int i = 0; i < 4; i++){
            r.x = c.x + dx[i];
            r.y = c.y + dy[i];
            if(r.x >= 0 && r.x < row && r.y >= 0 && r.y < column && !visit[r.x][r.y]
               && map[r.x][r.y] != 'S' && map[r.x][r.y] != 'R'){

                if(map[r.x][r.y] == 'T'){
                    return c.step + 1;
                }
                visit[r.x][r.y] = true;
                if(map[r.x][r.y] == 'E'){
                    r.step = c.step + 1;
                } else if(map[r.x][r.y] == 'B') {
                    r.step = c.step + 2;
                }
                Q.push(r);
            }
        }
        Q.pop();
    }
    return -1;
}


int main()
{
    while(scanf("%d%d",&row,&column), row || column){
        int sx,sy;
        for(int i = 0 ; i < row; i++){
            scanf("%s",map[i]);
        }
        for(int i = 0 ; i < row; i++){
            for(int j = 0; j < column; j++){
                if( map[i][j] == 'Y'){
                    sx = i;
                    sy = j;
                    break;
                }
            }
        }
        printf("%d\n",bfs(sx,sy));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值