poj1679 The Unique MST(判定次小生成树)

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23180 Accepted: 8235

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source

对于最小生成树(可以用kruskal和prime算法求得,在这里我是用kruskal求得,如果不会请自己百度。),边的权值的和最小称为最小生成树。

而次小生成树就是除了最小生成树外的最小生成树。而且所有的次小生成树都是通过最小生成树的换边得到的。

所以难点就是如何换边。

对于如何换边:

1.先求出最小生成树,值为x。

2.一一枚举添加不在生成树上的边(这时候一定形成了一个环)

3.寻找环上的(最小生成树上的边)权值最大值与你所添加不在生成树上的边的权值比较,所得到的差值为min。

由于是一一枚举添加边,min有多个,求出最小的哪一个,所以次小生成树就为x+min。


昨天虽然把这道题A了,可是看到讨论区的测试数据发现自己又一个没有过,然而却AC了。然后今天起床就来研究研究。。。

发现我的程序是在找最大值,可是如果一个环有分支,它还会去找分支里面的最大值,于是就又优化了一下。

用的优先队列。

先附上第一次做的代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node 
{
	int a,b,cost;
}c[10005];
int fa[105],tree[105][105],vis[10005],vis_tree[105];//vis数组是对m对数据的标记vis_tree是对最小生成树标记
int n,m,max1;
bool cmp(node x,node y)
{
	if(x.cost<y.cost) 
	return true;
	else
	return false;
}
int find(int x)//寻找根
{
	if(fa[x]!=x) fa[x]=find(fa[x]);
	return fa[x];
}
void sec_tree(int a,int b)//查找生成树某条边的最大值(我在这里做的是错误的,如果形成的环有分支,也会查找)
{
	vis_tree[a]=1;
	if(a==b)
	return ;
	for(int i=1;i<=n;i++)
	if(tree[a][i]&&!vis_tree[i])
	{
		if(max1<tree[a][i])
		max1=tree[a][i];
		sec_tree(i,b);
	}
}
int main()
{
	int ncase;
	scanf("%d",&ncase);
	while(ncase--)
	{
		memset(vis,0,sizeof(vis));
		memset(tree,0,sizeof(tree));
		memset(&c,0,sizeof(&c));
		scanf("%d %d",&n,&m);
		for(int i=1;i<=n;i++)
		fa[i]=i;
		for(int i=0;i<m;i++)
		scanf("%d %d %d",&c[i].a,&c[i].b,&c[i].cost);
		sort(c,c+m,cmp);
		int sum=0;
		for(int i=0;i<m;i++)//kruskal算法求最小生成树
		{
			int x=find(c[i].a);
			int y=find(c[i].b);
			if(x!=y)
			{
				fa[x]=y,sum+=c[i].cost;
				tree[x][y]=tree[y][x]=c[i].cost;
				vis[i]=1;
			}
		}
		int flag=0;
		for(int i=0;i<m;i++)
		{
			if(!vis[i])//不在生成树中的边和形成的环的最大值比较。如果相等,MST不唯一
			{
				max1=-1;
                                memset(vis_tree,0,sizeof(vis_tree));
				sec_tree(c[i].a,c[i].b);
				if(max1==c[i].cost)
				{
					flag=1;
					break;
				}
			}
		}
		if(!flag)
		printf("%d\n",sum);
		else
		printf("Not Unique!\n");
	}
}

这是优化后的代码,注释和上面一样,就一个地方不同:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;
struct node1
{
	int a,b,cost;
	friend bool operator<(node1 x,node1 y )
	{
		return x.cost<y.cost;
	}
};
priority_queue<node1>s;
struct node 
{
	int a,b,cost;
}c[10005];
int fa[105],tree[105][105],vis[10005],vis_tree[105];
int n,m,max1,flag1;
bool cmp1(node x,node y)
{
	if(x.cost<y.cost) 
	return true;
	else
	return false;
}
int find(int x)
{
	if(fa[x]!=x) fa[x]=find(fa[x]);
	return fa[x];
}
void sec_tree(int a,int b)
{
	node1 temp;
	vis_tree[a]=1;
	if(a==b)//如果找到a=b,标记一下
	{
		flag1=1;
	}
	for(int i=1;i<=n;i++)
	if(tree[a][i]&&!vis_tree[i])
	{
		temp.a=a,temp.b=i,temp.cost=tree[a][i];
		s.push(temp);
		if(!flag1)//就是在这里和上面不同,如果找不到a=b,那么就把以前的恢复
		s.pop(),vis_tree[i]=0,sec_tree(i,b);
	}
}
int main()
{
	int ncase;
	scanf("%d",&ncase);
	while(ncase--)
	{
		memset(vis,0,sizeof(vis));
		memset(tree,0,sizeof(tree));
		memset(&c,0,sizeof(&c));
		scanf("%d %d",&n,&m);
		for(int i=1;i<=n;i++)
		fa[i]=i;
		for(int i=0;i<m;i++)
		scanf("%d %d %d",&c[i].a,&c[i].b,&c[i].cost);
		sort(c,c+m,cmp1);
		int sum=0;
		for(int i=0;i<m;i++)
		{
			int x=find(c[i].a);
			int y=find(c[i].b);
			if(x!=y)
			{
				fa[x]=y,sum+=c[i].cost;
				tree[x][y]=tree[y][x]=c[i].cost;
				vis[i]=1;
			}
		}
		int flag=0;
		for(int i=0;i<m;i++)
		{
			if(!vis[i])
			{
				int flag1=0;
				while(!s.empty())
				s.pop();
				memset(vis_tree,0,sizeof(vis_tree));
				sec_tree(c[i].a,c[i].b);
				node1 temp;
				temp=s.top();
				if(temp.cost==c[i].cost)
				{
					flag=1;
					break;
				}
			}
		}
		if(!flag)
		printf("%d\n",sum);
		else
		printf("Not Unique!\n");
	}
}


  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值