HDU4902 Nice Boat(14多校联合4-1006)线段树区间更新

Nice boat

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1743    Accepted Submission(s): 314


Problem Description
  
  
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli. Let us continue our story, z*p(actually you) defeat the 'MengMengDa' party's leader, and the 'MengMengDa' party dissolved. z*p becomes the most famous guy among the princess's knight party. One day, the people in the party find that z*p has died. As what he has done in the past, people just say 'Oh, what a nice boat' and don't care about why he died. Since then, many people died but no one knows why and everyone is fine about that. Meanwhile, the devil sends her knight to challenge you with Algorithm contest. There is a hard data structure problem in the contest: There are n numbers a_1,a_2,...,a_n on a line, everytime you can change every number in a segment [l,r] into a number x(type 1), or change every number a_i in a segment [l,r] which is bigger than x to gcd(a_i,x) (type 2). You should output the final sequence.
 

Input
  
  
The first line contains an integer T, denoting the number of the test cases. For each test case, the first line contains a integers n. The next line contains n integers a_1,a_2,...,a_n separated by a single space. The next line contains an integer Q, denoting the number of the operations. The next Q line contains 4 integers t,l,r,x. t denotes the operation type. T<=2,n,Q<=100000 a_i,x >=0 a_i,x is in the range of int32(C++)
 

Output
  
  
For each test case, output a line with n integers separated by a single space representing the final sequence. Please output a single more space after end of the sequence
 

Sample Input
  
  
1 10 16807 282475249 1622650073 984943658 1144108930 470211272 101027544 1457850878 1458777923 2007237709 10 1 3 6 74243042 2 4 8 16531729 1 3 4 1474833169 2 1 8 1131570933 2 7 9 1505795335 2 3 7 101929267 1 4 10 1624379149 2 2 8 2110010672 2 6 7 156091745 1 2 5 937186357
 

Sample Output
  
  
16807 937186357 937186357 937186357 937186357 1 1 1624379149 1624379149 1624379149

题意:给n个数,m次询问,给定一个区间a,b和一个数x。两种操作,一种是把区间内全部替换成x,另一种则是把区间内比x大的数替换成其与x的最大公约数。求m次操作之后这n个数分别是多少。

解法:由于数据较大,很自然地想到线段树。由于本人实力有限,只想到了最简单的情况。即是维护一个区间之内是不是相同,如果相同则记录其值,然后按题意一直更新即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#define rep(i,a,b)	for (int i=a;i<(b+1);i++)
#define lson (2*k)
#define rson (2*k+1)
#define N 600000
#define mid ((p[k].l+p[k].r)>>1)
#define ll long long 
using namespace std;
int n;
int ans[N]={0};
struct P{
	int l,r;
	ll num;
}p[N];
void push_dn(int k){
	if (p[k].num>0){
		p[lson].num=p[rson].num=p[k].num;
		p[k].num=0;
	}
}
void push_up(int k){
	if (p[lson].num==p[rson].num)	p[k].num=p[lson].num;
}
void up1(int k,int l,int r,ll x){
	if (l<=p[k].l&&r>=p[k].r){
		p[k].num=x;
		p[lson].num=p[rson].num=x;
		return ;
	}
	push_dn(k);
	p[k].num=0;
	if (l<=mid)	up1(lson,l,r,x);
	if (r>mid)	up1(rson,l,r,x);
	push_up(k);
}
void up2(int k,int l,int r,ll x){
	if (l<=p[k].l&&r>=p[k].r&&p[k].num>0){
		if (p[k].num>x)
			p[k].num=__gcd(x,p[k].num);
		return ;
	}
	push_dn(k);
	if (l<=mid)	up2(lson,l,r,x);
	if (r>mid)	up2(rson,l,r,x);
	push_up(k);
}

ll query(int k,int l,int r,int o){
	if (l==r)	return p[k].num;
	push_dn(k);
	if (o<=mid)	query(lson,l,mid,o);
	else return query(rson,mid+1,r,o);
}
void build(int k,int l,int r){
	p[k].l=l,p[k].r=r;
	if (l==r){
		scanf("%I64d",&p[k].num);
		return ;	
	}
	build(lson,l,mid);
	build(rson,mid+1,r);
}
int main(){
	int T;
	scanf("%d",&T);
	rep(z,1,T){
		memset(p,0,sizeof p);
		scanf("%d",&n);
		build(1,1,n);
		int Q;
		scanf("%d",&Q);
		rep(i,1,Q){
			int t,a,b;
			ll x;
			scanf("%d%d%d%I64d",&t,&a,&b,&x);
			if (t%2)	up1(1,a,b,x);
			else up2(1,a,b,x);
		}
		rep(i,1,n)	printf("%I64d ",query(1,1,n,i));
		puts("");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值