hdu1358 Period

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2524    Accepted Submission(s): 1245


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
  
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
  
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 


一直在思索这个题目,发现自己对next数组理解还是不深刻。

举个简单的例子:

i012345678910111213
straabaabaabaab\0
next[i]-1010123456789


GetNext函数的时候可以取得12的next值。i为11时,比较不相等,返回到8,意味着在11的时候,比较不相等,跳转至8的位置。为什么跳转到8呢?因为之前的都相等,而8和11位置处的关系不确定,所以跳至8的位置。当然,可以优化GetNext算法。

//============================================================================
// Name        : KMP_hdu1358.cpp
// Author      : vit
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <string.h>
#include <stdio.h>

using namespace std;

int i, j, m ,n;
char str[1000001];
int next[1000001];
int ch;
int no;

void GetNext() {
	j = 0;
	i = -1;
	next[0] = -1;
	while (j < n) {
		if (i == -1 || str[i] == str[j]) {
			i++, j++;
			next[j] = i;
		} else {
			i = next[i];
		}
	}
}

int main() {
	no = 1;
	while(cin >> n){
		if(n == 0)
			break;
		scanf("%s", str);
		GetNext();
		printf("Test case #%d\n", no);
		no++;
		for(i = 2; i <= n; i++){
			ch = i - next[i];
			if(i % ch == 0){//可以想成(i - 1) - 0 + 1
				if(i / ch > 1){//重复次数大于1
					printf("%d %d\n",i,i / ch);
				}
			}
		}
		printf("\n");
	}
	return 0;
}



//优化的算法

void GetNextval(){//用此算法生成的nextval数组,不能用上面的算法进行计算。原因很简单:把相同的串重复跳转判断的部分放在了nextval生成里面,所以减少KMP的比较次数的同时,也造成了无法找到重复串的次数。
	j = 0;
	i = -1;
	nextval[0] = -1;
	while(j < n){
		if(i == -1 || str[i] == str[j]){
			i++, j++;
			if(str[i] == str[j])
				nextval[j] = i;
			else
				nextval[j] = nextval[i];
		} else
			i = nextval[i];
	}
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值