Period
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6632 Accepted Submission(s): 3202
Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
求循环串和它的循环数
在kmp中我们发现next数组就是求下次走的一个进位数,因此如果你当前所在的位置能够整除你的进位,且进位大于1,那就代表你当前处于有周期循环状态、
我们用i%(i-nextt[i])来判断是否为循环串,为0就是,然后用i/(i-nextt[i])作为循环数。
#include <iostream>
#include <cstdio>
#include <cstring>
#define N 1000010
using namespace std;
char str[N];
int nextt[N],n;
void get_next()
{
int i,k;
i=0,k=-1;
memset(nextt,0,sizeof(nextt));
nextt[0]=-1;
while(str[i])
{
if(k==-1||str[i]==str[k])
{
i++,k++;
nextt[i]=k;
}
else
k=nextt[k];
}
}
void kmp()
{
int i;
for(i=2;str[i-1];i++)
{
int t=i-nextt[i];
if(i%t==0&&i/t>1)//<----------有点难理解
printf("%d %d\n",i,i/t);
}
}
int main()
{
int c=1;
while(scanf("%d",&n)!=EOF&&n)
{
scanf("%s",str);
printf("Test case #%d\n",c++);
get_next();
kmp();
printf("\n");
}
return 0;
}