UVa 10038 / POJ 2575 / ZOJ 1879 Jolly Jumpers (water ver.)

119 篇文章 0 订阅
12 篇文章 0 订阅

10038 - Jolly Jumpers

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=979

http://poj.org/problem?id=2575

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1879

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

1 4 2 3
is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

Input

Each line of input contains an integer n <= 3000 followed by n integers representing the sequence.

Output

For each line of input, generate a line of output saying "Jolly" or "Not jolly".

Sample Input

4 1 4 2 3
5 1 4 2 -1 6

Sample Output

Jolly
Not jolly

注意有两个可以提前退出循环的条件。


完整代码:

/*UVa: 0.012s*/
/*POJ: 16ms,184KB*/
/*ZOJ: 0ms,204KB*/

#include<cstdio>
#include<cstring>
#include<cstdlib>

int arr[3010], vis[3010];

int main(void)
{
	int n, i;
	while (~scanf("%d", &n))
	{
		memset(vis, 0, sizeof(vis));
		for (i = 0; i < n; i++)
			scanf("%d", &arr[i]);
		bool flag = true;
		for (i = 1; i < n; i++)
		{
			if (abs(arr[i] - arr[i - 1]) >= n)
			{
				flag = false;
				break;
			}
			if (vis[abs(arr[i] - arr[i - 1])]++) ///小技巧~
			{
				flag = false;
				break;
			}
		}
		puts(flag ? "Jolly" : "Not jolly");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值