1857-Jolly Jumpers ZCMU

Description

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

Each line of input contains an integer n < 3000 followed by n integers representing the sequence. For each line of input, generate a line of output saying "Jolly" or "Not jolly".

Sample Input

4 1 4 2 3

5 1 4 2 -1 6

Sample Output

Jolly

Not jolly

解析

题意是给你一个n个元素的序列。每连续的两个元素的差的绝对值要>=1&&<=n-1,并且每个差的绝对值只能出现一次,这样这个序列才是Jolly,否则是Not jolly

思路

再开一个数组val[],记录每个差值出现的次数

代码

#include<bits/stdc++.h>
#define MAX 10005
using namespace std;
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int arry[MAX],val[MAX],i;
        for(i=0;i<n;i++)
        {
            scanf("%d",&arry[i]);
        }
        memset(val,0,sizeof(val));
        int flag=1;
        for(i=0;i<n-1;i++)
        {
            int temp=abs(arry[i]-arry[i+1]);
            if(temp>=1&&temp<=n-1)
            {
                val[temp]++;
            }
            else
                flag=0;
        }
        if(flag)
        {
          for(i=1;i<=n-1;i++)
          {
            if(val[i]==0||val[i]>=2)
            {
               flag=0;
               break;
            }
          }
        }
        if(flag)
            printf("Jolly\n");
        else
            printf("Not jolly\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值