中国剩余定理算法详解 + POJ 1006 Biorhythms 生理周期

119 篇文章 0 订阅
100 篇文章 0 订阅
先放上POJ的题目:

Biorhythms

Time Limit:  1000MS
Memory Limit: 10000K

Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days. 

Use the plural form ``days'' even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

Source


题目翻译:

Description

人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。在高峰这天,人会在相应的方面表现出色。例如,智力周期的高峰,人会思维敏捷,精力容易高度集中。因为三个周期的周长不同,所以通常三个周期的高峰不会落在同一天。对于每个人,我们想知道何时三个高峰落在同一天。对于每个周期,我们会给出从当前年份的第一天开始,到出现高峰的天数(不一定是第一次高峰出现的时间)。你的任务是给定一个从当年第一天开始数的天数,输出从给定时间开始(不包括给定时间)下一次三个高峰落在同一天的时间(距给定时间的天数)。例如:给定时间为10,下次出现三个高峰同天的时间是12,则输出2(注意这里不是3)。

Input

输入四个整数:p, e, i和d。 p, e, i分别表示体力、情感和智力高峰出现的时间(时间从当年的第一天开始计算)。d 是给定的时间,可能小于p, e, 或 i。 所有给定时间是非负的并且小于365, 所求的时间小于21252。 

当p = e = i = d = -1时,输入数据结束。

Output

从给定时间起,下一次三个高峰同天的时间(距离给定时间的天数)。 

采用以下格式: 
Case 1: the next triple peak occurs in 1234 days. 

注意:即使结果是1天,也使用复数形式“days”。



中国剩余定理(CRT,Chinese Reminder Theory,又称孙子定理)

介绍:(参考《初等数论及其应用》)




PS:例中数据与实际的物不知数问题略有出入。


此题相当于解方程组

x+d≡p(mod 23)

x+d≡e(mod 28)

x+d≡i(mod 33)

由于23,28,33两两互素,所以M=23*28*33=21252,M1=924,M2=759,M3=644.

则有924y1≡1(mod 23),由924/23=(40,5,1,3)计算得y1=6(mod 23)

则有759y2≡1(mod 28),由759/28=(27,9,2,1)计算得y2=19(mod 28)

则有644y3≡1(mod 33),由644/33=(19,1,1,16)计算得y3=2(mod 33)

因此x+d≡(5544p+14421e+1288i)(mod 21252)

即x=(5544*p+14421*e+1288*i-d)%21252

本题所求的是最小整数解,避免x为负,因此最后结果为x=(x+21252)%21252
那么最终求解x的表达式就是:

x=(5544*p+14421*e+1288*i-d+21252)%21252

(若x为0,就令x为21252


完整代码:

/*16ms,248KB*/

#include<cstdio>
using namespace std;

int main()
{
	int p, e, i, d, icase = 0, x;
	while (scanf("%d%d%d%d", &p, &e, &i, &d), ~p)
	{
		x = (5544 * p + 14421 * e + 1288 * i - d + 21252) % 21252;
		if (x == 0) x = 21252;
		printf("Case %d: the next triple peak occurs in %d days.\n", ++icase, x);
	}
	return 0;
}


****转载请注明来源: http://blog.csdn.net/synapse7/article/details/9946013****

  • 5
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值