HDU 2642 Stars (二维树状数组)

129 篇文章 0 订阅
77 篇文章 8 订阅

Stars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 2495    Accepted Submission(s): 1034


Problem Description

Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.
There is only one case.

 

Input

The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.

 

Output

For each query,output the number of bright stars in one line.

 

Sample Input

5

B 581 145

B 581 145

Q 0 600 0 200

D 581 145

Q 0 600 0 200

 

Sample Output

1

0

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2642

题目大意:给一个二维区域,B表示将对应坐标的星星点亮,D表示将对应坐标的星星熄灭,Q询问一个子区域中亮着的星星个数

题目分析:二维树状数组维护即可

#include <cstdio>
#include <algorithm>
using namespace std;
int const MAX = 1005;
int m, x1, y1, x2, y2, sum[MAX][MAX];
bool sta[MAX][MAX];

int lowbit(int x) {
    return x & (-x);
}

int add(int x, int y, int val) {
    for (int i = x; i < MAX; i += lowbit(i)) {
        for (int j = y; j < MAX; j += lowbit(j)) {
            sum[i][j] += val;
        }
    }
}

int query(int x, int y) {
    int ans = 0;
    for (int i = x; i > 0; i -= lowbit(i)) {
        for (int j = y; j > 0; j -= lowbit(j)) {
            ans += sum[i][j];
        }
    }
    return ans;
}

int main() {
    scanf("%d", &m);
    char s[2];
    while (m--) {
        scanf("%s", s);
        if (s[0] == 'B') {
            scanf("%d %d", &x1, &y1);
            x1++; y1++;
            if (!sta[x1][y1]) {
                add(x1, y1, 1);
                sta[x1][y1] = true;
            }
        } else if (s[0] == 'D') {
            scanf("%d %d", &x1, &y1);
            x1++; y1++;
            if (sta[x1][y1]) {
                add(x1, y1, -1);
                sta[x1][y1] = false;
            }
        } else {
            scanf("%d %d %d %d", &x1, &x2, &y1, &y2);
            x1++; y1++;
            x2++; y2++;
            if (x1 > x2) {
                swap(x1, x2);
            }
            if (y1 > y2) {
                swap(y1, y2);
            }
            printf("%d\n", query(x2, y2) + query(x1 - 1, y1 - 1) - query(x1 - 1, y2) - query(x2, y1 - 1));
        }
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值