HDU 2642 stars 二维树状数组




Stars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 633    Accepted Submission(s): 269


Problem Description
Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.

There is only one case.
 

Input
The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.
 

Output
For each query,output the number of bright stars in one line.
 

Sample Input
  
  
5 B 581 145 B 581 145 Q 0 600 0 200 D 581 145 Q 0 600 0 200
 

Sample Output
  
  
1 0
 


话说,这是最最裸的二维树状数组,只要掌握了基本的树状数组,在二维的数组里每次更新或是查询的时候多一步操作的可以了~


#include <cstdio>
#include <iostream>
#include <string.h>
#include <vector>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int map[1005][1005];
int visit[1005][1005];
int lowbit( int t )
{
    return t&(-t) ;   
}

int query( int x , int y )
{
    int sum = 0;
    int ry ;
    while( x > 0 ){
           ry = y;
           while( ry > 0 ) {
                  sum += map[x][ry];
                  ry -= lowbit( ry );
           }
           x -= lowbit( x );
    }
    return sum;
}

void update( int x ,  int y , int val )
{    
     int ry;
     while( x < 1005 )
     {
            ry = y;
            while( ry < 1005 ){
                   map[x][ry] += val;
                   ry += lowbit( ry );
            }
            x += lowbit( x );
     }
}

int main( )
{
    int n;
    while( scanf("%d",&n) != EOF )
    {
           getchar();
           memset( map , 0 , sizeof(map) );
           memset( visit , 0 , sizeof(visit) );
           char s[10];
           int x1,x2,y1,y2;
           int maxx , maxy , minx, miny;
           while( n-- ){
                  scanf("%s",s);
                 if( s[0] == 'B' ){
                     scanf("%d%d",&x1,&y1);
                     if( visit[x1+1][y1+1] == 0 ){
                         visit[x1+1][y1+1] = 1;
                         update( x1+1 , y1+1 , 1 );
                     }
                     
                 }
                 else if( s[0] == 'D' ){
                      scanf("%d%d",&x1,&y1);
                      if( visit[x1+1][y1+1] == 1 ){
                          update( x1+1 , y1+1 , -1 );
                          visit[x1+1][y1+1] = 0;
                      }
                 }
                 else if( s[0] == 'Q' ){
                      scanf("%d%d%d%d",&x1,&x2,&y1,&y2);
                      maxx = max( x1 , x2 );
                      maxy = max( y1 , y2 );
                      minx = min( x1 , x2 );
                      miny = min( y1 , y2 );
                      int ret1 , ret2 , ret3 , ret4;
                      ret1 = query(maxx+1 , maxy+1);
                      ret2 = query( maxx+1 , miny );
                      ret3 = query( minx , maxy+1 );
                      ret4 = query( minx , miny );
                      printf("%d\n", ret1 + ret4 - ret3 - ret2 );     
                 }
           }
    }
    return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值