zoj3329(概率DP,分解因式求系数)

地址:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3754

One Person Game

Time Limit: 1 Second       Memory Limit: 32768 KB       Special Judge

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698

题意:有三个骰子,分别有k1,k2,k3面。但三个骰子分别掷到a,b,c点时得分归零,否则加上三个骰子的点数。

            当得分超过n时游戏结束,问结束游戏需要的步数的期望。

思路:基本套路。但有一点不同的是,在本题p[0]在执行每一步时都会被调用,而此时p[0]的值还未确定。所以这里讲p[0]设为x,当循环执行到求p[0]再将x解开就行了。

代码:

#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
//#include<algorithm>
using namespace std;
double p[510][2];  //因为不能设x,所以这里开两个数组[0]保存常数,[1]保存p[0]的系数
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,k1,k2,k3,a,b,c,num[20]={0};
        scanf("%d%d%d%d%d%d%d",&n,&k1,&k2,&k3,&a,&b,&c);
        for(int i=1;i<=k1;i++)
            for(int j=1;j<=k2;j++)
                for(int k=1;k<=k3;k++)
                    num[i+j+k]++;
        num[a+b+c]--;
        p[n+1][0]=p[n+1][1]=0;int m=k1*k2*k3;
        for(int i=n;i>=0;i--)
        {
            p[i][0]=1;p[i][1]=1.0/m;
            for(int j=3;j<=k1+k2+k3;j++)
                for(int k=0;k<2;k++)
                    p[i][k]+=num[j]*1.0/m*p[min(n+1,i+j)][k];
        }
        double ans=p[0][0]/(1-p[0][1]);  //最后解开方程
        printf("%.15lf\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值