poj2923(状态压缩+01背包)

地址:http://poj.org/problem?id=2923

Relocation
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1667 Accepted: 679

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers nC1 and C2C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3

题意:A君和B君要搬家,他们叫了2辆车来搬n件家具,家具的重量和车的承重已给出。问最少要几趟才能搬完家。

思路:因为最多只有10件家具,所以用状态压缩。将家具分别组合起来,找出可以搬运的组合,求搬运不重复组合的最小值。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MA 0xfffffff
int n,v1,v2,vol[20],dp[1050],val[1050];
int yasuo(int s)
{
    int i=1,j,sum=0,vis[1050];
    memset(vis,0,sizeof(vis));
    vis[0]=1;
    while(s)
    {
        if(1&s)
        {
            sum+=vol[i];
            for(j=v1;j>=vol[i];j--)
                if(vis[j-vol[i]]) vis[j]=1;
        }
        s=s>>1;i++;
    }
    for(i=0;i<=v1;i++)
        if(vis[i]&&sum-i<=v2)  //这里是一个重点:这个判断将两辆车和为一辆来看。
            return 1;
    return 0;
}
int main()
{
    int t,cas=1,i,j,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&v1,&v2);
        for(i=1;i<=n;i++) scanf("%d",&vol[i]);
        m=0;
        for(i=1;i<(1<<n);i++)
        {
            if(yasuo(i))
                val[m++]=i;  //另开一个数组来储存可运送的组合。
            dp[i]=MA;
        }dp[0]=0;
        for(i=0;i<m;i++)
        {
            for(j=(1<<n)-1;j>=0;j--)
            {
                if(dp[j]==MA) continue;
                if((j+val[i])==(j|val[i]))  //这里是判断已运送的家具和要运送的家具是否重复。
                {
                    dp[j+val[i]]=min(dp[j]+1,dp[j+val[i]]);  //这里注意:因为是最小值,所以用min;又因为是求容量和,所以前面是j+val[i]。
                }
            }
        }
        printf("Scenario #%d:\n%d\n\n",cas++,dp[(1<<n)-1]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值